Port Royale 3 - crash reports and technical bugs thread
#1
Please use this thread to report game crashes and technical bugs of Port Royale 3.

For gameplay bugs: Thread
Ehrenamtlicher / Voluntary Moderator
Ich bin im Forum rein ehrenamtlich tätig. Mein Posting spiegelt nicht zwingend die Meinung von Kalypso Media wider.
I'm acting as moderator on a voluntary basis. My posting does not necessarily represent Kalypso Media positions.
Reply
#2
Hi. I just installed, patched and started game today. But i am suffering crashes randomly. I started free play, entered 2nd city. When it says '' Entering city'' sound went into loop and kept going like that. Wheel was spinning in loading screen but sound was looping. So i had to enter task manager and closed the game. Then i started another free play, the same thing happened at the beginning of free play. Could you help me ? Thanks.
Reply
#3
(04-05-2012, 04:59 PM)Perkendes Wrote: Hi. I just installed, patched and started game today. But i am suffering crashes randomly. I started free play, entered 2nd city. When it says '' Entering city'' sound went into loop and kept going like that. Wheel was spinning in loading screen but sound was looping. So i had to enter task manager and closed the game. Then i started another free play, the same thing happened at the beginning of free play. Could you help me ? Thanks.

This is a known issue that affects certain dual core CPUs only and will be fixed shortly.

UPDATE: It is already fixed in the 1.1.0.24502 version released on Steam today.
Reply
#4
@perkendes
Sounds like you are on Windows XP - Vista or Win 7 would give an error message - but before anything else.

Make sure you have applied any patches offered via the Kalypso Launcher
Run Windows Update - and apply all the "High Priority" fixes
Run Windows Update - and apply any Optional Hardware fixes
Ensure your graphics drivers are up to date - Check your manufacturer’s web site
Ensure your sound card drivers are up to date - Check your manufacturer’s web site
Check your PC manufacturer’s web site for firmware updates

If you are still getting problems or crashes - then post your DXDIAG here - in tags #/# with any error message AND send it with a brief description to KALYPSO support. Then you have 2 chances to get help.
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Timo posted just while I was but the advice stands for most issues
Reply
#5
(04-05-2012, 05:05 PM)billyplod Wrote: @perkendes
Sounds like you are on Windows XP - Vista or Win 7 would give an error message - but before anything else.

Not necessary, in my case it's Win7 x64 and it's rather a hard freeze and you have to ctrl-atl-del to get the taskman open.
Same problem in the german board as well - but the issue seems to be gettin' addressed already Tongue
Reply
#6
I am using Win7 64 and drivers are up to date too. I don't think it will be a big problem with upcoming patches, as Timo said. Game released today and things like that are absolutely normal. I am just addressing my issue so developers can check Smile
Reply
#7
(04-05-2012, 05:05 PM)Timo Wrote:
(04-05-2012, 04:59 PM)Perkendes Wrote: Hi. I just installed, patched and started game today. But i am suffering crashes randomly. I started free play, entered 2nd city. When it says '' Entering city'' sound went into loop and kept going like that. Wheel was spinning in loading screen but sound was looping. So i had to enter task manager and closed the game. Then i started another free play, the same thing happened at the beginning of free play. Could you help me ? Thanks.

This is a known issue that affects certain dual core CPUs only and will be fixed shortly.
Any approximate time when it will be fixed? I am anxious to continue to play the game.
Reply
#8
Devs,

Running the game in Steam, the game crashes if you try to ALT+TAB away while in fullscreen mode (Win 7 64bit, Nvidia graphics, Dual-monitor). This means I can't switch away from the game for a few moments (to read emails, etc) without quitting and restarting. I could run in non-fullscreen mode, but then I can't scroll my moving the mouse to the edge of the map.

Thanks
Reply
#9
I also crash instantly on opening, with the classic windows 7 "Port Royale 3 has stopped working" message here are the details it they help.

Code:
Problem Event Name:    APPCRASH
  Application Name:    PortRoyale3.exe
  Application Version:    1.1.0.24502
  Application Timestamp:    4fa3b87b
  Fault Module Name:    PortRoyale3.exe
  Fault Module Version:    1.1.0.24502
  Fault Module Timestamp:    4fa3b87b
  Exception Code:    c0000005
  Exception Offset:    003a535c
  OS Version:    6.1.7601.2.1.0.768.3
  Locale ID:    1033
  Additional Information 1:    0a9e
  Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:    0a9e
  Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

I have a i7 with a Radeon 6870 on Win7 32bit. Cache verified and all drivers up to date.
Reply
#10
Greetings.

Immediately application crash.

Steam Port Royale 3. (Integrity of game cache - verified)
Windows XP SP3 x86.
CPU: Intel Core 2 Duo E8500
ATI Radeon 5870 (drivers 12.4, single monitor)

Any suggestions?

Log:
Code:
<MATCHING_FILE NAME="AppData.exe" SIZE="670024" CHECKSUM="0xF5198BD5" BIN_FILE_VERSION="3.0.0.0" BIN_PRODUCT_VERSION="3.0.0.0" PRODUCT_VERSION="3.0.0.0" FILE_DESCRIPTION="Port Royale 3" COMPANY_NAME="Kalypso Media GmbH" PRODUCT_NAME="PR3 STEAM AppData" FILE_VERSION="3.0.0.0" ORIGINAL_FILENAME="AppData.exe" INTERNAL_NAME="AppData.exe" LEGAL_COPYRIGHT="Copyright © Kalypso Media GmbH 2012" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0xB04A6" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="3.0.0.0" UPTO_BIN_PRODUCT_VERSION="3.0.0.0" LINK_DATE="04/20/2012 16:15:07" UPTO_LINK_DATE="04/20/2012 16:15:07"
Reply
#11
(04-05-2012, 09:25 PM)Schrademan Wrote: Hi,

I have installed the Steam 1.1 version, and the game crashes to desktop immediately after I press the play button.

I have an i7 processor, GTX 680 graphics card, Windows 7 64, my pc is up to date on all it's patches and software updates.

is this common to steam games? this is my first time to get a game via d/l and steam and same thing with me.
Reply
#12
(04-05-2012, 09:37 PM)canucks33 Wrote: is this common to steam games? this is my first time to get a game via d/l and steam and same thing with me.
No. it's don't.
Reply
#13
If you are using the STEAM version then try to "Verify Local Files" for the game.
Another thing to try is chnaging your download node.
SELECT
STEAM from the menu
SETTINGS - Downloads & Cloud TAB - and change your "Download region" to another UK Node
Then verify files

@TheDudeAbides
Yes I think that FULL SCREEN problem is an issue - but if you play Full Screen - just ALT / ENTER to switch to Windowed mode - check your mail and the ALT TAB - back to game and the ALT / ENTER back to full screen
Reply
#14
Game crashes immediately after I click play.

Here is the Windows Event Application Error report:

Faulting application name: PortRoyale3.exe, version: 1.1.0.24502, time stamp: 0x4fa3b87b
Faulting module name: PortRoyale3.exe, version: 1.1.0.24502, time stamp: 0x4fa3b87b
Exception code: 0xc0000005
Fault offset: 0x003a535c
Faulting process id: 0x668
Faulting application start time: 0x01cd2a2bdfd2bf91
Faulting application path: C:\Program Files\Steam\steamapps\common\port royale 3\PortRoyale3.exe
Faulting module path: C:\Program Files\Steam\steamapps\common\port royale 3\PortRoyale3.exe
Report Id: 1dc914bf-961f-11e1-8e3a-001cc0dec8f5
Faulting package full name:
Faulting package-relative application ID:

Oh, and I'm running Windows 8, 32 bit version.
Reply
#15
Quote:If you are using the STEAM version then try to "Verify Local Files" for the game.
Already done. In this case - doesn't help at all.
Reply
#16
(04-05-2012, 09:21 PM)TheDudeAbides Wrote: Devs,

Running the game in Steam, the game crashes if you try to ALT+TAB away while in fullscreen mode (Win 7 64bit, Nvidia graphics, Dual-monitor). This means I can't switch away from the game for a few moments (to read emails, etc) without quitting and restarting. I could run in non-fullscreen mode, but then I can't scroll my moving the mouse to the edge of the map.

Thanks

Hi there, just tried doing it myself and it worked fine, could be an issue with the newest nvidia drivers though. I'm still using the 295.73 drivers /w 3x580GTXes and an nvidia surround triple display setup and its letting me alt-tab back and forth fine. I have met other games where this was an issue but so far PR3 is working fine for me with the alt-tabbing.

Do you have Aero disabled by chance? It could be the act of flipping from 3D down to 2D and back again that might be causing your issues if that's the case.
Reply
#17
(04-05-2012, 09:52 PM)BumpInTheNight Wrote:
(04-05-2012, 09:21 PM)TheDudeAbides Wrote: Devs,

Running the game in Steam, the game crashes if you try to ALT+TAB away while in fullscreen mode (Win 7 64bit, Nvidia graphics, Dual-monitor). This means I can't switch away from the game for a few moments (to read emails, etc) without quitting and restarting. I could run in non-fullscreen mode, but then I can't scroll my moving the mouse to the edge of the map.

Thanks

Hi there, just tried doing it myself and it worked fine, could be an issue with the newest nvidia drivers though. I'm still using the 295.73 drivers /w 3x580GTXes and an nvidia surround triple display setup and its letting me alt-tab back and forth fine. I have met other games where this was an issue but so far PR3 is working fine for me with the alt-tabbing.

Do you have Aero disabled by chance? It could be the act of flipping from 3D down to 2D and back again that might be causing your issues if that's the case.

Weird, it's working for me now too, but it crashed twice earlier. I tried it with menus open, on the caribbean screen, and on a town screen, and it worked fine all times. I'll update with conditions if it happens again.

EDIT: I had it minimized as I was typing that, and when I clicked on the taskbar icon to restore, it crashed again. I think it was from a town screen, no menus open.
Reply
#18
I'm using Steam, Win7, Nvidia drivers and it crashes immediately after I click play as well.

I am super pissed; I'll try to contain my language here.

I paid for this game. This game should JUST WORK. I shouldn't have to check 40,000 things, wait for a patch, sign up for a forum so I can post... etc etc etc... spending hours of time trying to get the game to JUST DO WHAT I PAID FOR IT TO DO.

Why oh why do you people F up like this. Im buying a game on steam with a normal computer.. and it doesnt work right out of the box... how do you let this crap happen.

I have downloaded 4 games from steam in the last week and they all worked... I paid for this one and it doesnt.... QUIT SHIPPING PRODUCTS THAT DONT WORK GOOOOOOOOOOOOOOOOOOD DAMNNNNNNNIT
Reply
#19
(04-05-2012, 10:09 PM)chumpstar Wrote: I am also getting "Port Royale 3 has stopped working..." message. I have reinstalled twice. The error occurs immediately after DirectX (step 1 of 1) happens. I'm hoping since other people are experiencing the same thing a solution will come up soon because I can't wait to play it!

I sit here in amazement... PC games have enough problems without them not working out of the box (or steam in this case). I should buy the game, click install, click play.... and be done with it. Now I sit here wondering should I get my money back or wait who knows how long for them to address this. Why on earth wasnt this tested...
Reply
#20
(04-05-2012, 10:09 PM)chumpstar Wrote: I am also getting "Port Royale 3 has stopped working..." message. I have reinstalled twice. The error occurs immediately after DirectX (step 1 of 1) happens. I'm hoping since other people are experiencing the same thing a solution will come up soon because I can't wait to play it!

im with you. i dont really get it why have the 4 months difference between retail and getting it through d/l.
Reply
#21
Guys, stay cool. This is technical bugs thread.
Posting negative reaction doesn't help to solve crash problems. Let's discuss dev competition in another thread.
Reply
#22
(04-05-2012, 09:57 PM)TheDudeAbides Wrote: EDIT: I had it minimized as I was typing that, and when I clicked on the taskbar icon to restore, it crashed again. I think it was from a town screen, no menus open.

Blarg, I've been alt-tabbing a few times now and yah it did just crash now when I tried again. Seems fairly random but indeed not a good situation.
Reply
#23
Port Royale 2 was awesome, i still have CD and can install and play it anytime, no need of updates.
And this thing suck, really. Its normal nowadays launch unready products and think that people will eat this. meh
Reply
#24
Shy @FGART: may I ask u a few questions? Are u a nerd? Are u fine with registering "all over the world" only to receive "0" of help? Do you have time to waste? That you can spent whole days for waiting for at least stupid answers like "have you updated this or that?"

Or are you one of those lucky bastards who don't care about money because "daddy did it"? And therefore it doesnt matter if you're spending time AND money for products that don't work?

So if you can't understand some decent critics on business behaviour and insufficent and malfunctioning products, you really should keep your lame advice deep down where it obviously came from.

It sucks, if you pay and download a software that doesn't work at all! It also sucks, if there is no help (by the way, your mastery advice doesn't help either) and it sucks even more, not to get any helpfull tip.

So, dear support guys: I also downloaded by steam and got a major crash from the beginning, and yes, my drivers ARE up to date and so is Windows. And more: yes, I checked data integrity and re-installed.

MANY thanks to anybody who really takes care of that issue.

greets
The SupportWant-er

***** update *****
Big Grin great one, my dear admins! Got "rep -1" with my first ask for help...instead of complaining about people threads you should try to work on help and solutions, oh great master of thread-ceremony
Reply
#25
I think this classes as a bug? All of my drivers are up to date and my hardware more than meets the standards, yet I only see this:
[Image: http://s18.postimage.org/e9b2bc41h/Capture.jpg]

Any solution?
Reply
#26
For anyone having issues with the Steam version launching, please try following these steps: https://support.steampowered.com/kb_arti...-EYON-2343

Also try restarting Windows after the initial installation as a couple of third party components (DirectX, .net Framework, VisualC++) may need a reboot in order to work properly.
Reply
#27
(04-05-2012, 11:02 PM)SupportWanted Wrote: Big Grin great one, my dear admins! Got "rep -1" with my first ask for help...instead of complaining about people threads you should try to work on help and solutions, oh great master of thread-ceremony

That was me actually, because of your inflammatory and useless addition to this thread. Its a new release, they always draw out issues and unfortunately those with unpredicted system combos sometimes end up with CTDs out of the box, no need to get into insults over something as trivial as a game or those asking to keep a more civil discourse.
Reply
#28
(04-05-2012, 11:25 PM)Timo Wrote: For anyone having issues with the Steam version launching, please try following these steps: https://support.steampowered.com/kb_arti...-EYON-2343

Also try restarting Windows after the initial installation as a couple of third party components (DirectX, .net Framework, VisualC++) may need a reboot in order to work properly.

Not working
Reply
#29
So there is the Steam alt-tab CTD, and hopefully Timo's patch above fixed that.

Any word on the dual-core, infinite-loop, during town load screens?
Reply
#30
Just adding another still not working post. Everything is up to date, I have checked just about everything I can think of, but I still do not even have a clue as to what is causing the problem.
Reply




Users browsing this thread: 2 Guest(s)