Port Royale 3 - crash reports and technical bugs thread
(05-05-2012, 11:16 PM)Timo Wrote:
(05-05-2012, 11:10 PM)Defiant Wrote: Why are the English versions still waiting then?

Because the Launcher update for the English version has not fully passed QA before the weekend. Sorry for the inconvenience.
So apart from the language there's major differences for QA [Image: http://i492.photobucket.com/albums/rr285...sednew.gif]
Reply
I am having the Steam launch issue as well. PMd you my account name.
Reply
(05-05-2012, 11:44 PM)hex2323 Wrote: I am having the Steam launch issue as well. PMd you my account name.

Done the same here pmed you my Steam account name Timo, ta.
Permission to install the torrent version with my steam key at my own risk and peril request pleease?
Reply
(05-05-2012, 11:35 PM)Defiant Wrote:
(05-05-2012, 11:16 PM)Timo Wrote:
(05-05-2012, 11:10 PM)Defiant Wrote: Why are the English versions still waiting then?

Because the Launcher update for the English version has not fully passed QA before the weekend. Sorry for the inconvenience.
So apart from the language there's major differences for QA [Image: http://i492.photobucket.com/albums/rr285...sednew.gif]


I know, it's inconvenient, but let them do what's necessary. Just imagine you get a buggy patch which fries your machine. The crowd would scream for blood and heads!
I am sure there are several people trying to solve all issues. It's just we're all human in need of rest and sleep and some even have family...Wink So please be patient, perhaps there will be a pleasant surprise on Sunday morning.
Reply
Please add me to this list of crash on launch.
Reply
(05-05-2012, 11:50 PM)Crasharrrrg Wrote: Please add me to this list of crash on launch.

Your Steam name is the same as in this forum?
Please send Timo a message with your Steam name, I think that's easier for him than going through the forum to look for people.
Reply
Thanks everyone again, there's no need for further Steam names. Further investigations have not lead to new findings on the issue, but we're back at suspecting the dependencies (DirectX 9, .net and VisualC++).

In particular, make sure you download and install this: http://download.kalypsomedia.com/support/dotnetfx3.exe

and this: http://download.kalypsomedia.com/support...otNet3.exe
Reply
Any new news im still with the issue of "port royale 3 has stopped working" I need to play so i can get my Lets play going ahha! quick plug OptimusBrit Wink
Reply
(05-05-2012, 11:50 PM)athrun Wrote:
(05-05-2012, 11:35 PM)Defiant Wrote:
(05-05-2012, 11:16 PM)Timo Wrote:
(05-05-2012, 11:10 PM)Defiant Wrote: Why are the English versions still waiting then?

Because the Launcher update for the English version has not fully passed QA before the weekend. Sorry for the inconvenience.
So apart from the language there's major differences for QA [Image: http://i492.photobucket.com/albums/rr285...sednew.gif]


I know, it's inconvenient, but let them do what's necessary. Just imagine you get a buggy patch which fries your machine. The crowd would scream for blood and heads!
I am sure there are several people trying to solve all issues. It's just we're all human in need of rest and sleep and some even have family...Wink So please be patient, perhaps there will be a pleasant surprise on Sunday morning.
Well considering we can't play the game now it wouldn't really matter would it. I'm quite happy to have a beta of this "patch" now before the official release of it?
Reply
Quote:I know, it's inconvenient, but let them do what's necessary. Just imagine you get a buggy patch which fries your machine. The crowd would scream for blood and heads!
I am sure there are several people trying to solve all issues. It's just we're all human in need of rest and sleep and some even have family...Wink So please be patient, perhaps there will be a pleasant surprise on Sunday morning.

Hey no fair it's 8am Sunday morning where I am already, hehehe.
Quote:Posted by Timo - Today 07:55 AM
Thanks everyone again, there's no need for further Steam names. Further investigations have not lead to new findings on the issue, but we're back at suspecting the dependencies (DirectX 9, .net and VisualC++).

Darn the fix sounds like it'll take a while if we're going all the way back to square one :/
Reply
(06-05-2012, 12:01 AM)Tasslehoff Wrote: Hey no fair it's 8am Sunday morning where I am already, hehehe.

0:01am Sunday morning here. Cool
Reply
(05-05-2012, 11:55 PM)Timo Wrote: Thanks everyone again, there's no need for further Steam names. Further investigations have not lead to new findings on the issue, but we're back at suspecting the dependencies (DirectX 9, .net and VisualC++).

In particular, make sure you download and install this: http://download.kalypsomedia.com/support/dotnetfx3.exe

and this: http://download.kalypsomedia.com/support...otNet3.exe
Done. Same error. Crash at startup.
Reply
(05-05-2012, 11:55 PM)Timo Wrote: Thanks everyone again, there's no need for further Steam names. Further investigations have not lead to new findings on the issue, but we're back at suspecting the dependencies (DirectX 9, .net and VisualC++).

In particular, make sure you download and install this: http://download.kalypsomedia.com/support/dotnetfx3.exe

and this: http://download.kalypsomedia.com/support...otNet3.exe

If it makes any difference, the dotnetfx3.exe also does not appear to actually do anything. The system clocks for about a second (by clocks I mean that my mouse cursor spins for a moment) then nothing happens. There isn't even a Windows Log event created.

When I try running the EnableDotNet3.exe program, the same thing happens, but it actually generates the following event log:

Skipping creation of restore point (Process = C:\WINDOWS\winsxs\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.2.8250.0_none_917833b36d163729\TiWorker.exe -Embedding; Description = Windows Modules Installer) as there is a restore point avaliable which is recent enough for System Restore.
Reply
same Steam problem here. Opened a ticket...let's hope that thing will be done by tomorrow. Kudos to Timo...it's half past 12 here...and I am off to bed. Seems like you got a long night ahead of you. Wink

(06-05-2012, 12:08 AM)FGART Wrote:
(05-05-2012, 11:55 PM)Timo Wrote: Thanks everyone again, there's no need for further Steam names. Further investigations have not lead to new findings on the issue, but we're back at suspecting the dependencies (DirectX 9, .net and VisualC++).

In particular, make sure you download and install this: http://download.kalypsomedia.com/support/dotnetfx3.exe

and this: http://download.kalypsomedia.com/support...otNet3.exe
Done. Same error. Crash at startup.

In particular, make sure you download and install this: http://download.kalypsomedia.com/support/dotnetfx3.exe

This thing doesn't even do the full monty here: Error Message half way through. Didn't screenshot...silly me.
Reply
does it matter that when I try to install dotnetfx3.exe it fails because i have a later version installed?

here is an image of the error

http://imageshack.us/photo/my-images/6/netg.png/
Reply
Maybe this .net Cleanup Tool is worth a try: http://blogs.msdn.com/b/astebner/archive...04493.aspx (use at own risk, I can't officially support this)
Reply
With WIN 7 and Vista 64bit operating systems - DOTNET3 is part of the operating system - you may or may not get error messages telling you that it isn't going to install. Usually the system default is - no message - , so you run it and nothing seems to happen.

That is why.
Reply
Frustrating Sad I go out to dinner, sleep and wake up to still no one having an idea of what the issue is.

So I've registered now 24 hours later in being able to "run" the product, in order to make a few points in my own situation:

* I have Patrician 4 and Patrician 4 RoAD installed, through steam. Both still work perfectly.
* I have bought 35 steam games in my lifetime. This is the first one, ever, that has not worked. I find it disingenuous that steam has been blamed. I personally believe it was an exercise in buying Kalypso support time to find the real issue. I am not surprised that you've had to backtrack on that one.
* I have done all the steps asked of as far as patching/ checking for updates. Everything was (as I suspected) up to date, and in one case, is of a more recent version that is being asked for.

Where I now come to point out what may be obvious, but not yet tried by Kalypso:

You've asked users to run .net versions 3(x?) and dx9. I personally run .Net 4 (with 3 and 3.5 also installed) and DirectX 9.0c (4.09.0000.0904). Does the launcher attempt to find old/older versions of these components, if no - attempt to install them and the install fails (naturally - because theres a more up to date version) therefore the launcher fails?

(06-05-2012, 12:52 AM)Timo Wrote: Maybe this .net Cleanup Tool is worth a try: http://blogs.msdn.com/b/astebner/archive...04493.aspx (use at own risk, I can't officially support this)

Oh god please don't ask people to do that!!!!!! I have specific programs that require the different versions of .Net in order to run. You're potentially now stuffing around with people's entire systems.

To get PR3 to work should NOT have to require only one version of .NET!
Reply
(05-05-2012, 10:42 PM)O4epegb Wrote:
(05-05-2012, 10:35 PM)ragebane Wrote: Well, I bought the game on steam and downloaded the torrent of the game. Instead of hurting the company by pirating the software via crack and requesting a refund through steam, I just simply used the product code I purchased and am now able to play the game without the install issue with Steam. The issue is clearly not on Kalypso's end, so why hurt the company? I would recommend doing this to all those people who really want to play the game and support the developers (but have already bought the game on Steam), but don't want to wait for Steam to get around to fixing it.

And you haven't got freezes when you go into and from town?

I am having the problem sometimes because of the lack of update. I suppose I will just wait for them to release the English update.
Reply
@madamjess
Not an issue - the registry will point at the version that each program needs if it's a bespoke application and the .NET versions are backwards compatible like DirectX
Reply
Quote:Oh god please don't ask people to do that!!!!!! I have specific programs that require the different versions of .Net in order to run. You're potentially now stuffing around with people's entire systems.

To get PR3 to work should NOT have to require only one version of .NET!

It might be something to with missing registry entries or if the (behind the scenes?) steam installer fails. If the CD version can load the kalypso launcher to the the enter your CD key up perfectly fine and not the steam version on the same system *cough* it's obviously not because the .nets/directx/vb c++ are not installed correctly.
Reply
(06-05-2012, 01:01 AM)billyplod Wrote: @madamjess
Not an issue - the registry will point at the version that each program needs if it's a bespoke application and the .NET versions are backwards compatible like DirectX

That's what I also thought last year when I thought I'd clean up. Perhaps it's been addressed in KB's lately, but I had grief with a couple of work specific applications that for some reason didnt use it mutually exclusively :/
Reply
You can have all versions of .net installed of course, this will not be an issue for the game or interfere with anything. I just posted the cleanup tool as it reportedly fixes incomplete or faulty installations of individual .net versions. Unfortunately, .net is *not* backwards compatible, so you definitely need 3.0 and/or 3.5 running alongside 4.0 if that's what the game requires.
Reply
Hi,
I have seen all the videos show the global map with Islands, land, boats and water.

But when I look at the global map all I see is cities, boats and all water (no land at all).
I am running with the latest NVidia drivers (brand new laptop) on Win7 64 ultimate and GTX 560M graphics card.

Just for info I run a 23" monitor attached to my laptop (I have to run the game in windowed mode to avoid screen flicker, but everything else should be fine).

I have tried tweaking all the graphics settings in Port Royale 3 but nothing makes the land appear on the global map.

Please can someone help me, or at least someone else confirm they have the same bug so that I know I am not going mad

Many thanks in advance for help.
Reply
(06-05-2012, 01:18 AM)Sargentbash Wrote: Hi,
I have seen all the videos show the global map with Islands, land, boats and water.

But when I look at the global map all I see is cities, boats and all water (no land at all).
I am running with the latest NVidia drivers (brand new laptop) on Win7 64 ultimate and GTX 560M graphics card.

You need to disable Nvidia 3D Vision from the Nvidia control panel.
Reply
It saddens me to think that Steam have not yet made comment on why their own system will not run this game correctly... I pre-ordered this game a little while ago and I've been somewhat over-excited about it due to my enjoyment of the previous two games. I'm most upset I am unable to 'click and play' because of an issue which should not have occured in the first place. Yet I remain patient as I know it will be as awesome as the last two when I can eventually play it.

I think it would just be respectful for Steam to make comment on their own system failers however and to give some reassurance that the issue will be resolved in a reasonable time...
Reply
(06-05-2012, 01:19 AM)Timo Wrote:
(06-05-2012, 01:18 AM)Sargentbash Wrote: Hi,
I have seen all the videos show the global map with Islands, land, boats and water.

But when I look at the global map all I see is cities, boats and all water (no land at all).
I am running with the latest NVidia drivers (brand new laptop) on Win7 64 ultimate and GTX 560M graphics card.

You need to disable Nvidia 3D Vision from the Nvidia control panel.

Wow that has to be the fastest reply and fix for any game I have ever played! Big Grin
Perfect, thank you so much!
Reply
For those that have the game crashing every 2 minutes is there anything we can do as a temporary measure while you "QA" the English version of the patch
Reply
(06-05-2012, 01:16 AM)Timo Wrote: You can have all versions of .net installed of course, this will not be an issue for the game or interfere with anything. I just posted the cleanup tool as it reportedly fixes incomplete or faulty installations of individual .net versions. Unfortunately, .net is *not* backwards compatible, so you definitely need 3.0 and/or 3.5 running alongside 4.0 if that's what the game requires.

It may also be worth noting that Windows 8 (I assume this is similar to Windows 7) treats .net 3.0 and 3.5 as Windows Features, not separate programs. They don't appear in the installed programs list. I have to click on "Turn Windows features on or off" in order to see the .net installations. So, I tried disabling .net from there, rebooting, then using the .net installer found in the game file. Instead of using the installer, Windows pulls up a box that says "Windows needs the following app to run this program" and if you tell it to install, then it simply installs the .net feature via the "Turn Windows features on or off" instead of using the .net installer.
Reply
posting a link here to the 'Game Time Frozen' thread because i want to make sure it's recognized as a bug
http://forum.kalypsomedia.com/showthread.php?tid=14399
Reply




Users browsing this thread: 2 Guest(s)