Port Royale 3 - crash reports and technical bugs thread
(06-05-2012, 11:13 AM)portroyale3russia Wrote: Where are the developers?
Can Kalypso provide an .exe that will work? Would be a great thing to have. ...

Don't you mean where were the beta testers Rolleyes
Reply
(06-05-2012, 01:21 PM)Defiant Wrote: Don't you mean where were the beta testers Rolleyes

It seems to me that they were not, those that test in steam. In fact, we are beta testers Steam, bought the game. Sad

!!
Reply
I would be happy to link the exe somewhere but until you get a successful install, I don't think that will help.

(link removed by Kalypso, this contains an outdated game executable)
Reply
So I downloaded the torrent, installed it WITHOUT using any stupid mounting BS. crap. Just use WinRar to unpack it and install it. After that I did try to copy only PortRoyale3.exe, but that didn't work well. So I also had to copy the torrent data.fuk file over to steam game folder. And now at least I got the game to launch!!!
Reply
(06-05-2012, 01:29 PM)Crasharrrrg Wrote: I would be happy to link the exe somewhere but until you get a successful install, I don't think that will help.

(link removed by Kalypso, this contains an outdated game executable)

Thank you very much are a gentleman

Works for me so far
Reply
(06-05-2012, 01:32 PM)Scrangle Wrote: I've gotten the game to work but like people here are saying: The game crashes regularly when entering towns making it very difficult to progress. Other then the startup problem this issue must be addressed ASAP.

Option 1:

Start the game and go into task manager->processes and set affinity on Portroyale3.exe to just one processor.

Option 2:

Put the following command in to the shortcut target line

C:\Windows\System32\cmd.exe /C start /affinity 1 "C:\Program Files (x86)\Kalypso Media\Port Royale 3\PortRoyale3.exe"

and write PortRoyale3.exe when cmd pops up.

(note! the path to cmd and pr3 might be different on your system)

This will make the crashes less frequent, but they will still occur.
Reply
(06-05-2012, 01:29 PM)Crasharrrrg Wrote: I would be happy to link the exe somewhere but until you get a successful install, I don't think that will help.

(link removed by Kalypso, this contains an outdated game executable)
exe worked for me either.
Reply
none of the secondary installations have helped..
Reply
(06-05-2012, 01:27 PM)portroyale3russia Wrote:
(06-05-2012, 01:21 PM)Defiant Wrote: Don't you mean where were the beta testers Rolleyes

It seems to me that they were not, those that test in steam. In fact, we are beta testers Steam, bought the game. Sad

!!

Forget it anyway because even if you get it working on steam it crashes when you enter a town and they were more concerned about fixing the German version than the international one.......................hell the patches can't even be that much different!
Reply
(06-05-2012, 01:29 PM)Crasharrrrg Wrote: I would be happy to link the exe somewhere but until you get a successful install, I don't think that will help.

(link removed by Kalypso, this contains an outdated game executable)

Yep, this version did work with the steam data.fuk file... But still it's the old 1.1.0 - 24450 version. I'm not sure if 24502 is any better for Duo processors. But in any case. At least we got it to launch.
Reply
what should be the version number for non-steam version after patched?
Reply
(06-05-2012, 02:31 AM)plast Wrote:
(06-05-2012, 02:24 AM)Defiant Wrote:
(06-05-2012, 02:04 AM)plast Wrote:
(06-05-2012, 01:46 AM)Defiant Wrote: For those that have the game crashing every 2 minutes is there anything we can do as a temporary measure while you "QA" the English version of the patch

If you having the issue with entering/leaving towns try this (worked for me):

-> Start the game
-> go to option to select window mode
-> Go in to task manager (crtrl alt del) and Processes
-> Find PortRoyale3.exe and select Set Affinity
-> Set it to just Cpu 0

Ah yes that should work if it is a core problem like they said

Did the trick for me, but remember to save quite frequent though. I still get occasional crashes, but now it's like 1/40 of every town I enter, whereas before it was almost every other time.
Didn't work in the end and these guys don't seem to be in any rush to fix corrupt product they put on the open market
Reply
The .exe the fine poster put on dropbox works with my Steam version as well. It's the only thing that works. This shows it is NOT any of the dependencies. It's Steam's version of the .exe

But Steam doesn't aknowledge this. They keep sending 'canned' responses.

Well, I guess the exe will sit on my desktop to pop in the steam folder whenever steam changes back to the crap exe.

At least I can play now...
Reply
yes dropbox works fine Smile
Reply
(06-05-2012, 01:29 PM)Crasharrrrg Wrote: I would be happy to link the exe somewhere but until you get a successful install, I don't think that will help.

(link removed by Kalypso, this contains an outdated game executable)

You Sir are a genius! I salut you. It worked. Got a CTD after 20 Min but hey! It works.
Reply
what the hell, iggy_w32.dll not found...

sorted, seems to be working.. skidrow version with steam code..
Reply
(06-05-2012, 02:55 PM)Belly Button Dwarf Wrote:
(06-05-2012, 01:29 PM)Crasharrrrg Wrote: I would be happy to link the exe somewhere but until you get a successful install, I don't think that will help.

(link removed by Kalypso, this contains an outdated game executable)

You Sir are a genius! I salut you. It worked. Got a CTD after 20 Min but hey! It works.

Well said

At last we can play what we paid for
Just save your game quite often

Still where are the developers that have taken our money?????
Reply
Sod it I'm putting Port Royale 2 on, at least that works and there is hardly any difference anyway
Reply
(06-05-2012, 01:29 PM)Crasharrrrg Wrote: I would be happy to link the exe somewhere but until you get a successful install, I don't think that will help.

(link removed by Kalypso, this contains an outdated game executable)

This works great for me too! Thanks very much!
Reply
I Have purchased the steam addition of this game and it doesnt even start up. I have deleted and downloaded again and the same thing has happened.
I noticed quite a few people from Australia is having the same problem.
Does anyone know why and has Kalypso notified Steam or given them a fix, a lot of people are not happy.Sad
Reply
Prk it's saying you should put that entire line as the target:

C:\Windows\System32\cmd.exe /C start /affinity 1 "E:\Games Instal\Port Royale 3\PortRoyale3.exe"

Then when you open the shortcut it should open a black window (command prompt) from there you have to type in:
PortRoyale3.exe which should then launch the game with the cpu affinity set appropriately.
Reply
Well, apparently I am the only one still unable to play.

I've used the provided .exe, the launcher fires, CD key from Steam and everyhting is fine, until it crashes again.

AppName: portroyale3.exe AppVer: 1.1.0.24450 ModName: portroyale3.exe
ModVer: 1.1.0.24450 Offset: 00038db0


Seems I have truly no luck with this game (or Steam) Sad.
Reply
(06-05-2012, 05:07 PM)athrun Wrote: Well, apparently I am the only one still unable to play.

I've used the provided .exe, the launcher fires, CD key from Steam and everyhting is fine, until it crashes again.

AppName: portroyale3.exe AppVer: 1.1.0.24450 ModName: portroyale3.exe
ModVer: 1.1.0.24450 Offset: 00038db0


Seems I have truly no luck with this game (or Steam) Sad.

You aren't the only one. There are many of us still silently waiting for a solution.
Reply
(06-05-2012, 05:07 PM)athrun Wrote: Well, apparently I am the only one still unable to play.

I've used the provided .exe, the launcher fires, CD key from Steam and everyhting is fine, until it crashes again.

AppName: portroyale3.exe AppVer: 1.1.0.24450 ModName: portroyale3.exe
ModVer: 1.1.0.24450 Offset: 00038db0


Seems I have truly no luck with this game (or Steam) Sad.

You are not alone, dude. I still have same problems:

Internal Error
App.cpp(1175): Error in 'App::Initialize':
Launcher failed return code: -532459699:0xe0434f4d
Reply
Setting port royal 3 to only run on 1 processor doesnt work. tried setting it to CPU 0 and the game crashed on the 3rd town i visited. Clearly this games isnt a finished product. I have now spend more timing trying to get this game to run via steam and keep it from crashing than i have spent playing it. Thats just not acceptable.
Reply
The app error is a generic COM error. Sadly it says nothing about what the true problem is. However, if I had to guess, something about the DRM is preventing some network (Steam) files from communicating with the launcher.
Reply
Gosh, the whole situation is outrageous.

I think I will have to find a working version. Shameful, truly shameful. Well, lesson learned regarding Steam. They're messing with the files and then they don't bother. My money was taken immediately, but then things are slowing down considerably.

I know I have to be more patient, but I don't want to learn it this way.

Shame

Athrun
Reply
This isnt a steam only error. Somewhere between Kalypso,Gaming Minds and steam some1 has botched up and giving steam a non working .exe file. But the game isnt even stabile once you get it running with the working .exe file. Normally refunds or compensations would be given out, had this been another product.
Reply
Still have the same issues with pressing play on steam and it says to me that it has stopped working! any new news Smile?

also how do you claim your money back or contact steam via telephone thanks xoxoxoxo
Reply
I keep having the steam crash issue, i follow the steps in this link https://support.steampowered.com/kb_arti...-EYON-2343 but everytime i reboot my computer or steam I have to follow it again, I mean at least the game works, but is there something i can do to stop this from reoccurring? I would prefer just to be able to click the game and play instead of having to go into my steam folder and do that everytime! BTW, for all of those having issue with the steam version, you simply need to follow the instructions in that link and it works, but you simply need to repeat the steps everytime you restart your pc it seems.

Please advise,

Nico.
Reply




Users browsing this thread: 1 Guest(s)