Port Royale 3 - crash reports and technical bugs thread
All the .NET issues fried my system and I spent a lovely Sunday reinstalling Windows.

And then, Steam decided to download the whole bloody 4.5 GB again.
Applying the provided .exe miraculously managed to start the game, but now the graphic is completely messy. I can't see any buttons, therefore trading and any activity is impossible.

I have taken a screeny of my blight.

http://tinypic.com/r/2q8zry0/6



Is this similar to the dual-core issue which was mentioned before?

Athrun
Reply
No, the dual core issue causes crash upon entering cities.

Maybe this helps, athrun:

#Post 186
Reply
@plast

Thought about this myself. To my understanding this is only for Nvidia cards, I am running an ATI Radeon X1950. I know, not the best one, but it worked very well for many years.

Well, tomorrow is a Monday and a working day, perhaps more people are getting interested in our small problem. I certainly hope so, because I don't want my money back, I want to play!
Reply
I just encountered a major crash in the game. Not when entering or leaving any town. I was sailing in the world level when my screen suddenly turned black. The only thing visible was the cursor (or the sable) flipping around the screen. Then I got the blue screen where Windows informed me that it had shut-down my computer.

OS: Windows Vista Ultimate 32-bit
Processor: Intel Core 2 Quad CPU, 2,40 GHz
Memory: 3,00 GB
Graphic card: ATI Radeon HD 3800 series
Reply
OK, now im confused, I actually managed to play the damn thing earlier today. I have just tried to start it again after a break and low and behold it wont play yet again. With the same problem. "PORT ROYALE 3 HAS STOPPED WORKING". How can it work at 12pm GMT and not work at 9pm GMT.
Reply
(06-05-2012, 10:12 PM)TEZBB Wrote: OK, now im confused, I actually managed to play the damn thing earlier today. I have just tried to start it again after a break and low and behold it wont play yet again. With the same problem. "PORT ROYALE 3 HAS STOPPED WORKING". How can it work at 12pm GMT and not work at 9pm GMT.
Looks like a weather's affected software syndrome Smile Well, on Windows XP Duke Nukem Forever starts only if u set a specific date and month (release date)...
Reply
I purchased the steam version of "Port Royale 3" and it crashes to desktop every time I try starting the game.
Reply
(06-05-2012, 10:37 PM)Raine Sage Wrote: I purchased the steam version of "Port Royale 3" and it crashes to desktop every time I try starting the game.

That might help: http://forum.kalypsomedia.com/showthread...#pid128142
Reply
(06-05-2012, 01:29 PM)Crasharrrrg Wrote: I would be happy to link the exe somewhere but until you get a successful install, I don't think that will help.

(link removed by Kalypso, this contains an outdated game executable)

This worked for me too - - way to go, Crasharrrrg!
Reply
(06-05-2012, 03:48 PM)Prki600 Wrote:
(06-05-2012, 01:46 PM)plast Wrote:
(06-05-2012, 01:32 PM)Scrangle Wrote: I've gotten the game to work but like people here are saying: The game crashes regularly when entering towns making it very difficult to progress. Other then the startup problem this issue must be addressed ASAP.

Option 1:

Start the game and go into task manager->processes and set affinity on Portroyale3.exe to just one processor.

Option 2:

Put the following command in to the shortcut target line

C:\Windows\System32\cmd.exe /C start /affinity 1 "C:\Program Files (x86)\Kalypso Media\Port Royale 3\PortRoyale3.exe"

and write PortRoyale3.exe when cmd pops up.

(note! the path to cmd and pr3 might be different on your system)

This will make the crashes less frequent, but they will still occur.

I do not understand this second step.This is my target line in shortcut properties "E:\Games Instal\Port Royale 3\PortRoyale3.exe".
What should I type instead?

Not sure if I did it right but I had to remove the /C string from the cmd program shortcut or it autocloses the command window and I still had to manually set the processor affinity to 1 however NO MORE CRASHES YAY! I used to be crashing almost all the time in isabella and every 4-5 ports.

Edit: Just did some research apparently there's no affinity option for the start command in XP 32bit so it has to be done manually. Scrounging interwebs for automaton hehe.

Edit 2: Okies for XP 32 bit users go to http://www.adsciengineering.com/StartAffinity/ and download the startAffinity binary 1.3.1 file, give the guy a small donation if your feeling generous, extract that to your portroyale3 gamefolder.
Create a new text(batch) file in the portroyale3 folder eg portroyale3.bat and EDIT it adding the following line
startaffinity portroyale3.exe 1
Then it's just a case of running the batchfile to start the game
[Image: http://i973.photobucket.com/albums/ae212...nity-2.jpg]
Reply
I have Steam version and I played it in my PC and it plays fine so far.

I tried it on my mac bootcamp and it worked fine at first but now when I start it up it wont open. It would just display the steam opening window then nothing will happen
Reply
Kinda boring to report, but I have the Appcrash problem too.

When i click on play in steam about 3 seconds later the Windows message with the appcrash appears.

all the .net fixes and reinstalltions didn't work an I am still sitting here, knowing I payed good money for a untested prduct.

This message goes to the developer Kalypsomedia:

it seems to be a problem with steam?
I don't care. I don't now how many people bought it through steam and have faced the exact same problem. If you publish it through such a provider than test it out before it goes live.

Try all the .net reinstallation and fixes?
I did this. I think hundrets of people did this. But I think I am one of hundrets who backuped his whole computer first, because such installtions, fixes and tweaks could destroy your OS. Hell it did happen to another user above.

All it needed was a fixed exe mentioned above. I will download it too and test it out, as soon as i'am back at my homecomputer.

MESSAGE TO ALL CUSTOMERS

Please show us and the developer, that you are unhappy with such a situation. PLEASE REGISTER on this forum and tell everyone your problem, even if its told thousand times before. It just cannot be, that a DRM does such a thing to the paying customer. Kalypso had more than enough time to create another EXE that will work and publish it on their homepage. But they didn't because they wont loose their copyprotection, even if such exe's are downloadable everywhere in the net.
Reply
Yes ! you are right.

shamefully, i'd play first skidrow version at moment and it was fun
so i deleted all of them and bought it.
i payed my money, and i can't play the game? Sad
what a manner for users !
Reply
jez, im in wisecracking mode^^

im pretty pissed with the support/situation as well, but:

kalypso is the publisher, not the developer. and steam is no part of kalypso Wink

so PLEASE DO REGISTER AND COMPLAIN but dont flame - at least not the wrong people, please Smile

steam fucked it up, they didnt even created a subforum for the game.. thats even worse customer service and support - not even providing a medium for customers to complain/ask/get support.. like i said, i pissed too but most of the problem was caused by steam, imho.
Reply
Is there any way to get a refund from steam? I doubt it since I dled the game already. I sent Steam a ticket 2 days ago. No response.

Is anyone still working on this???? (the Steam no start issue)
Reply
I am also getting the steam crash error. however now, i am not even getting that.

when attempting to launch out of steam all i get is a "This game is currently unavailable" message It's been like this since yesterday afternoon
Reply
I've been watching this forum since steam release as well, and the only thing that's helped me get my game up and running is the non standard .exe replacement fix. I had the issue where the game would crash as soon as steam attempted to launch it. My question is this: Kalypso knows that there is a solution to this problem to bypass steam for a game that we paid for. why not let us download the .exe file from them instead of getting it from questionable sources elsewhere? wouldn't they rather us get our game up and running through them instead of through skidrow via illegal torrents where we could get caught and charged for something we already own? And lastly, I know it's mostly steam's fault with their DRM protection, but this release was just terrible. I've never seen a game with so many glitches and faults go out on the market without any kind of refunds or attempt at making things better immediately. I paid almost 30-some bucks for a new game that in my opinion was worth 30-some bucks IF IT WORKED. this garbage isn't worth my time, frustration, money, or anything. I would at least like a partial refund for the multiple headaches and breaking of promises. And when this game finally gets fixed, I would love to play it and enjoy the new features.
Reply
Hi!

First of all, I want to thank you all for reporting your issues and a 'Sorry' for everyone who is still waiting for an answer.
I'll post a English version of the FAQ within the next days.

Our feedback:
We're noticed your issues. Furthermore, we're already building/testing a hotfix and we'll provide it as soon as possible.

Best regards,
Daan
Reply
thank you daan,

at least its some re-assurance that its being worked on.
Reply
Too little way too late. i have spend more time trying to get the game working than i have playing it, so now i just want a refund, since i have lost all faith in this product.
Reply
(07-05-2012, 06:05 PM)Marrec Wrote: Too little way too late. i have spend more time trying to get the game working than i have playing it, so now i just want a refund, since i have lost all faith in this product.

Agreed [Image: http://i106.photobucket.com/albums/m242/...ey/nod.gif]
Reply
@Marrec

The game is fine, thousands of people are playing, therefore I have faith. Annoyingly this is an exercise in patience, but I am sure it will be fixed very soon.

@all

Please keep in mind that Gaming Minds surely had no intention to ruin our experience and fun. Suggesting something so outlandish is ridiculous. It's just messy Windows, thousands of different hardware configurations and then, to top it, Steam comes along with their weird DRM policy. Perfect recipe for disaster, if you ask for my opinion. And it happened before with other games and developers and it will happen again and again.
Truly frustrating, but that's what things have come to in general. Patches have become a major (in)convenience of our modern time.

I will be patient and as they will get it under control, perhaps until the end of the week (I would LOVE to get the hotfix earlier *wink* *wink*).

Athrun
Reply
Steam users experiencing the launch issue (no error message), please read and try this: http://forum.kalypsomedia.com/showthread...#pid128819
Reply
@Athrun

The steam problem is that steam have/had a wrong portroyal3.exe file. even if you fixed this using the other .exe which is linked on this forum the game is still pretty unstabile with their dual core CTD upon entering/leaving a town.

Those errors are not windows errors but problems that the devs should have corrected prior to release. Had this been any other product we would have returned it and demanded a refund, since we bought a product which isnt working as intended.
Reply
@Daan:
Thanks for the update, it's nice to know that you're actually working on it and keeping us informed. Seeing as how we've already bought the broken game, would it be possible to let us into your hotfix while you're working on it to kinda test it ourselves as well? I'm pretty sure that since we've got nothing to lose on it, plus we'd be able to give you feedback, it's a win somewhere. thanks for your time.
Reply
A new bug first time, but i think its worth posting it.
Was playing with 3 Liners (uk ships) against a english military convoy strength about 150. Was fighting the combat when suddenly this appeared.

http://www.imagebam.com/image/4e1610189005534

and this is my dxdiag.(couldnt find a better place to put the file on in a short time + the dxdiag file is quite big so didnt want to spam the forum)

http://www.filefactory.com/file/1b4sxraw...DxDiag.txt
Reply
So what is going on? I bought two copies of the game for myself and a friend to play multiplayer.

Both were from steam. I used the dropbox download for the alternate .exe file to play and that got me running, and my system pretty much ok.

Friend however had the steam glitch as well, but when you get the alternate .exe it does not have the dual core fix so every time she enters a town game crashes making it unplayable multiplayer.

I thought 3 days later there would be a patch or something - is the patch there and I just don't see it?

I read that the german version is patched but the english version is not - is that the case? If you are an unlucky person with both the dual core processor and purchased from steam is there a timeframe when we can play the game?
Reply
hello. I downloaded port royale 3 first day it was released in new zealand. crashed instantly. That was quite a few days ago now. I have been following this forum watching and waiting for some kind of fix.

I quite franky don't care if its steams fault, kalypsos fault or the Queen of Englands fault. The fact of the matter is i paid for a game, That i have not been able to use.

I also do not have the time to balance two donkeys while crossing my fingers and hopping on one leg (pretty much amounts too some of the fixes that have been posted on here) I am just a simple gamer who wants a game to work. I don't belive thats too much to ask.

I am disgusted that you released a game that did not work.
Reply
Me again

So I installed the exe from the dropbox link and it worked like a charm. The sad thing is, after I getting rid of the Steam problem I run into the daual core CPU Problem. The first 20 Minutes I could play fine then after entereng a City the game freezes. I load the last checkpoint and could play for another 10 Minutes.

I like the game very much so far and for the start I am relieved, that I can play the game. But it still stinks how the support worked and that there is no patch or hotfix from official side.

I'am not willing to be a beta tester for a full priced Product. If you need a better beta testing please release a Demo fist!

I think to keep all those costumers in a good mood, kalypso and the developer (THANKS WYSE GUY) should show they're sorry about an incident like this and give something like a free downloadable content or similar. Otherwise I have to think situations like that are calculated in the process of publishing a game
Reply
(04-05-2012, 05:05 PM)Timo Wrote:
(04-05-2012, 04:59 PM)Perkendes Wrote: Hi. I just installed, patched and started game today. But i am suffering crashes randomly. I started free play, entered 2nd city. When it says '' Entering city'' sound went into loop and kept going like that. Wheel was spinning in loading screen but sound was looping. So i had to enter task manager and closed the game. Then i started another free play, the same thing happened at the beginning of free play. Could you help me ? Thanks.

This is a known issue that affects certain dual core CPUs only and will be fixed shortly.

UPDATE: It is already fixed in the 1.1.0.24502 version released on Steam today.

Hi Timo, I have deleted and re installed the steam version of this game and its still not even loading the game, any progress dude on game fixes on Steam. Cheers
Reply




Users browsing this thread: 2 Guest(s)