Port Royale 3 - Fehlerliste (Bugliste) - Version 1.3
#1
Port Royale 3 - Fehlerliste (Bugliste) - Version 1.3

Bitte tragt alle Fehler die ihr im Spiel findet in diesen Thread ein.

Hier geht es vor allem um Fehler im Gameplay!

Falls ihr technische Probleme habt, tragt diese bitte hier ein: Port Royale 3 - Technische Probleme

Voraussetzung zum Beziehen des automatischen Updates ist eine bestehende Internetverbindung sowie die Registrierung eines kostenlosen Kalypso Launcher Benutzerkontos.

Changelogs:
Version 1.1
Version 1.1.2
Version 1.1.3
Version 1.1.4
Version 1.2
Version 1.3




Bitte Erläuterungen von Daan Hugo beachten!


(08-05-2012, 05:49 PM)Daan Hugo Wrote: Hallo zusammen!
Vielen Dank, für die Meldungen. Wie Ihr vermutlich bereits an anderer Stelle gelesen habt, arbeiten wir bereits daran Mängel zu beseitigen. (D.h. die entsprechenden Mails habe ich bekommen)
Dennoch hier mal ein paar Infos zu den gemeldeten Themen:
- Option Städte zu schützen fehlt: Nein, es gibt den Patrouillienmodus
- Ansehen steigt/fällt: Das hat alles seine Richtigkeit. ...und ja, es ist nicht leicht....
- Seeschlachten(Kampf und Entern) zu schwer/leicht: Ich sehe hier keinen Grund für ein rebalancing, da es hier im Forum wohl 2 Lager gibt. Die einen finden es zu schwer, die anderen zu leicht. Es gibt auch die Funktion des Autokampfs oder die Möglichkeit mit weniger als 3 Schiffen zu Kämpfen.
- Einkauf durch Verwalter: Gibt es nicht und ist (an anderer Stelle bereits begründet) nicht gewollt.
- Sprengfass im Autokampf: Nein, es ist richtig, dass diese nur manuell verwendet werden können, da diese ja auch relativ teuer sind.
- Rechtsclick = Kaufen: Bitte dann den Rechtsklick nicht auf den Button zum Kaufen machen.
- Konzessionen abgeben: Nein, das geht nicht und war auch nie vorgesehen.
- Zeit läuft während Kämpfen weiter: Volle Absicht! (...auch im MP-Mode...)
- KI missachtet Untefen: Hängt vom Schifftyp ab. Manche haben weniger Tiefgang.
- Endlos-Belagerung und Time freeze: Ja, hier liegt ein Problem vor und wir haben es auf dem Schirm.
- Rechtschreibfehler: Falls welche außerhalb des Handbuchs auftreten, d.h. im Spiel, dann können mir diese gerne genannt werden. Optimal wäre dann der gesamte Satz.

Ich hoffe das beantwortet ein paar Fragen.

Beste Grüße,
Daan

Edit by Daan:
Noch ein paar weitere (aktuellere) Erläuterungen ab hier: http://forum.kalypsomedia.com/showthread...#pid129476
Ehrenamtlicher / Voluntary Moderator
Ich bin im Forum rein ehrenamtlich tätig. Mein Posting spiegelt nicht zwingend die Meinung von Kalypso Media wider.
I'm acting as moderator on a voluntary basis. My posting does not necessarily represent Kalypso Media positions.
Reply
#2
Hallo zusammen,

gerade im Spielverlauf ist bei mir ein schwerwiegender Bug aufgetreten, der das Spiel zwei Mal zum Absturz brachte. Ich konnte es danach jedoch nicht mehr reproduzieren, dennoch habe ich beim Versuch einen weiteren Fehler gefunden:

Version: 1.3.1.29131
Verwendete DLCs: Harbour Master

Testschritte:
1. Logbuch aufrufen
2. Aufgaben aufrufen
3. Oberste Aufgabe aufrufen (50 Waren nach Villa Hermosa liefern, je 25 Tuch und Kleidung) -> 2x Absturz!

Bei Versuch, den Fehler zu reproduzieren, wurde jedoch das Fenster geöffnet, bei dem mir angezeigt werden sollte, welche Waren geliefert werden sollen. Dort steht aber nun:
50 <img unknown> nach Villa Hermosa liefern
Bringt folgende Waren nach Villa Hermosa und verkauft sie an die Stadt:
Schließen (Button)

Es gibt anscheinend eine fehlerhafte Referenz zur Warenfass-Grafik, außerdem fehlen die Angaben und Grafiken zu den zu liefernden Waren.

Einen Screenshot kann ich hier nicht anhängen, hätte ich aber noch zur Verfügung, wenn gewollt.

Viele Grüße,
Rafael
Reply
#3
Ich kann den Fehler bestätigen. Habe auch die aktuelle Subversion von 1.3 und kein DLC installiert und seit ein wenigen Tagen kann ich keine Aufgaben mehr ohne Spielabsturz im Logbuch anschauen.

Einzige Ausnahme ist die Schatzkarte, die kann ich noch anschauen. Wenn es doch klappt, dass ich eine aktuelle oder vergangene Aufgabe mit Warenlieferung anklicken kann, dann sind die Grafiken die sonst angezeigt werden nicht vorhanden.

Warenlieferung wäre nicht ganz so schlimm, schlimmer finde ich, dass ich bei einer Schiffbrüchigenmission (für Schatzkarte) nicht mehr nachschauen kann, wohin der gebracht werden muss.
Reply
#4
Hi!

Das klingt nicht schön daher hatte ich jetzt mal versucht das Verhalten zu reproduzieren:
- Also das mit dem <img unknown> hatte ich schon mal gesehen (vor den Tests heute), aber wenn ich mich jetzt nicht irre sollte das bereits gefixt sein - zumindest tritt es bei mir nicht auf.
- Warenicons waren bei mir auch zu sehen.
- Abstürze hatte ich nicht dabei!
- Angabe der Zielorte war auch immer korrekt.

Daher mal folgende Fragen:
- Welche Version habt ihr bzw. woher habt ihr eure Version (Boxed aus einem Geschäft, Steam oder eine andere digitale Distribution)?
- Welche genaue Versionsnummer steht im Hauptmenü?
- Wenn es bei Euch reproduzierbar ist, dann wäre das Savegame mit Reproduktionsanleitung hilfreich (kann via E-Mail an den Support geschickt werden mit der bitte um Weiterleitung an mich)...

Grüße,
Daan
Reply
#5
(04-12-2012, 05:10 PM)Daan Hugo Wrote: Hi!

Das klingt nicht schön daher hatte ich jetzt mal versucht das Verhalten zu reproduzieren:
- Also das mit dem <img unknown> hatte ich schon mal gesehen (vor den Tests heute), aber wenn ich mich jetzt nicht irre sollte das bereits gefixt sein - zumindest tritt es bei mir nicht auf.
- Warenicons waren bei mir auch zu sehen.
- Abstürze hatte ich nicht dabei!
- Angabe der Zielorte war auch immer korrekt.

Daher mal folgende Fragen:
- Welche Version habt ihr bzw. woher habt ihr eure Version (Boxed aus einem Geschäft, Steam oder eine andere digitale Distribution)?
- Welche genaue Versionsnummer steht im Hauptmenü?
- Wenn es bei Euch reproduzierbar ist, dann wäre das Savegame mit Reproduktionsanleitung hilfreich (kann via E-Mail an den Support geschickt werden mit der bitte um Weiterleitung an mich)...

Grüße,
Daan

installierte Version: 1.3.1-29131 BS
Box aus Geschäft

einen Game-Stand der abstürzt und eine dxdiag-Analyse sind per Email an Support (mit Hinweis an dich Daan) raus gegangen.
Danke für den bisherigen Einsatz
Reply
#6
Wir haben das Verhalten heute auch reproduzieren können und haben die Quelle bereits identifiziert. An der Lösung arbeiten wir bereits!
Reply
#7
Super! Danke an euer Team.
Freue mich schon auf den Hotfix. Smile
Reply
#8
Ich habe die Downloadversion von Gamesload und den DLC von der Kalypsoseite. Exakte Version steht bereits im ersten Posting und die habe ich im Kalypso Launcher unten rechts abgelesen Smile Bei mir steht aber, im Vergleich zu padrone, kein BS dabei.
Viel Erfolg beim Patchen Smile
Reply
#9
Seit dem Build 29411 werden die Auftragsinformationen wieder richtig angezeigt. Gute Arbeit! Smile
Reply
#10
Hi Leute,

ich habe mir das Spiel vor ein paar Tage gekauft und erst einmal 4 h angespielt. Alles Top, keine Bugs!

Heute habe ich die Updates heruntergeladen...

Jetzt habe ich das Problem, dass nach einiger Zeit, oben wo man die 4 Nationen sieht, 4 mal England steht und alle 4 verbündet und grün sind.

Kann ich etwas machen um diesen Fehler zu beheben? Ich fürchte vor allem dass ich deshalb irgendwann nicht mehr in der Kampagne weitermachen kann...

Wäre für jeden Tipp dankbar!
Reply
#11
Das ist ein seltener Anzeigefehler, der aber keine Auswirkungen auf das Gameplay haben sollte. Wenn du die Geschwindigkeit auf ein min. reduzierst und dann ein Mal eine Stadt betrittst und wieder verlässt sollte wieder alles beim Alten sein. Im Zweifelsfall: Speichern und Laden Wink

Beste Grüße,
Daan
Reply
#12
Hallo, ich habe ein ernstes Problem und bin damit auch schon mit dem Kalypso Support am chatten (allerdings bisher erfolglos). Auf meiner großen Karte wird weder Land noch Wasser dargestellt. Ich sehe die Schiffe und ich sehe die bisher entdeckten Städte, alles andere ist einfach nur blau. Ich habe das Spiel inklusive aller DLC's vor ca. einer Woche über mein Steam Account gekauft. Alle aktuellen Hardware Treiber habe ich installiert, das Servicepack 1 für Windows 7 habe ich inzwischen auch drauf, auch gelöscht und noch einmal neu runtergeladen habe ich. Kalypso Support kann mir bisher nicht helfen. Falls irgendjemand ähnliche Probleme hatte und gelöst hat, wäre ich über Hilfe echt dankbar.

Hier meine Hardware:
System Manufacturer: ASUSTeK Computer Inc.
System Model: G73Sw
Processor: Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz (8 CPUs), ~2.0GHz
Memory: 4096MB RAM
Card name: NVIDIA GeForce GTX 460M

Beste Grüße und Danke im Voraus

Makami
Reply
#13
@Makami
stell mal die 3D-Darstellung der Grafikkarte ab, sollte über die NVidia-.Steuernung gehen.
Das Spiel selbst ist aktuell? Welche Versionsnummer wird im Menu angezeigt (links unten)?
Lebe jeden Tag, als wäre es Dein Letzter! / Live each day as it would be your last!
[Image: http://imghost4you.com/images/46.png]
Reply
#14
(17-01-2013, 11:41 AM)Dorimil Wrote: @Makami
stell mal die 3D-Darstellung der Grafikkarte ab, sollte über die NVidia-.Steuernung gehen.
Das Spiel selbst ist aktuell? Welche Versionsnummer wird im Menu angezeigt (links unten)?

1.3.2-29411 BS steht da. Die 3D-Darstellung schalte ich bei Simulationen und Strategiespielen immer direkt ab.
Ich krieg echt noch die Krise! :-(
Reply
#15
mmmhhh...auf den ersten Seiten dieses Threads gabs den Fehler auch schon und da war NVidia-3D-Vision der Verursacher...
Lebe jeden Tag, als wäre es Dein Letzter! / Live each day as it would be your last!
[Image: http://imghost4you.com/images/46.png]
Reply
#16
Hallo zusammen.
Muß leider noch einen kleinen Bug melden.
Die Erungenschaft " Heiratsglocken " verschwindet nach Neustart im Multiplayer.
Kleiner Bug aber trotzdem Ärgerlich, da man nur einmal heiratet. (Auf jedenfall in diesem Spiel)Big Grin
Reply
#17
Hatte diesen Fehler zwar schon woanders gepostet, aber bevor das sonst keiner sieht, hier mein Fehler:

Ich habe ein Problem mit "Stufe der Hafenbefestigung"...
Habe Port Royale, New Orleans usw eingenommen, die komplette Verteidigungsanlage wieder aufgebaut, aber trotzdem ist hinter dem Symbol mit den Kanonen eine "0"...

Hänge einen Screenshot mit an, da kann man es besser sehen.
Wäre gut das zu beheben, irritiert doch gewaltig... Danke!!!

Bild hier:
http://s1.directupload.net/file/d/3158/xxkejfo4_jpg.htm
Reply
#18
Also eines kann ja wohl nur ein Bug sein, folgendes Szenario:
Stadtangriff:
Ich greife eine Stadt (Georgtown) an, die hat 3 Befestigungsanlagen (2x800 und 1x1600 Stärke). Mache diese mit mehreren schnellen Anläufen platt, verliere die erste Landschlacht da ich nur noch 250 Soldaten hatte, stelle meinen Timer auf 0,1 (Geschwindigkeit), bringe meinen Konvoi durch klicken auf max wieder auf die höchste Leistung, gehe dann sofort wieder in den Stadtangriff und was muß ich sehen... DIE KOMPLETTE VETEIDIGUNGSANLAGE WURDE INNERHALB VON SEKUNDEN WIEDER KOMPLETT AUFGEBAUT...
WIE GEHT DENN SOWAS... DAS IST JA WEDER ANNEHMBAR NOCH IRGENDWIE ANNÄHERND REALISTISCH... ABER WEHE DIE GREIFEN MEINE STADT AN, DANN IST DA NICHTS MIT SEKUNDENAUFBAU...

BITTE BITTE ÄNDERT DAS...!!!!
Reply
#19
(01-03-2013, 01:47 AM)PCKlempner Wrote: Also eines kann ja wohl nur ein Bug sein, folgendes Szenario:
Stadtangriff:
Ich greife eine Stadt (Georgtown) an, die hat 3 Befestigungsanlagen (2x800 und 1x1600 Stärke). Mache diese mit mehreren schnellen Anläufen platt, verliere die erste Landschlacht da ich nur noch 250 Soldaten hatte, stelle meinen Timer auf 0,1 (Geschwindigkeit), bringe meinen Konvoi durch klicken auf max wieder auf die höchste Leistung, gehe dann sofort wieder in den Stadtangriff und was muß ich sehen... DIE KOMPLETTE VETEIDIGUNGSANLAGE WURDE INNERHALB VON SEKUNDEN WIEDER KOMPLETT AUFGEBAUT...
WIE GEHT DENN SOWAS... DAS IST JA WEDER ANNEHMBAR NOCH IRGENDWIE ANNÄHERND REALISTISCH... ABER WEHE DIE GREIFEN MEINE STADT AN, DANN IST DA NICHTS MIT SEKUNDENAUFBAU...

BITTE BITTE ÄNDERT DAS...!!!!
Hi!
Hierbei muss es sich nicht unbedingt um einen Bug handeln (und dies kannst du auch überprüfen wenn du mal selbst die Hafenanlagen ausbaust). Wenn genügend Bauwaren in der Stadt und ausreichend Geld in der Stadtkasse vorhanden sind, lässt sich die Verteidigung schnell wieder aufbauen. Du kannst auch mal versuchen mit mehreren Konvois (oder einem größeren) die Stadt erneut einzunehmen. Dabei solltest du feststellen, dass um so schneller/öfter du angreifst, desto schneller kannst du die Stadt auch einnehmen bzw. desto schlechter wird es der Stadt gelingen sich wieder von den Angriffen zu erholen Wink
Falls du erneut auf solche Probleme stoßen solltest, müsste ich wissen auf welcher Plattform du spielst und mir ggfs. das Savegame mal anschauen...

Beste Grüße,
Daan
Reply
#20
Danke für die Antwort, kann nur zu meiner "Verteidigung" sagen, daß Lehmziegel (also Bauwaren) knapp waren. Für mich bleibt da nur die Frage, kann die KI schneller wieder aufbauen als der Spieler? Es sind ja bei Geschwindigkeitsmodus 0.1 nur 5 Sekunden vergangen bis ich wieder rein bin zum Stadtangriff. Also ich schaffe das so schnell nicht Hafenanlagen wieder aufzubauen. Zumal die ja komplett "abgeschossen" wurde durch meine Schiffe und die Stärke von 1600 und 2 x 800 so schnell reparieren, das geht, finde ich, etwas zu schnell, wenn es ein Drittel wäre, ok, das könnte sein aber gleich 100%... Kann aber andererseits verstehen, es soll ja nicht allzu leicht gemacht werden, eine solch befestigte Stadt einzunehmen... Vielleicht gibt es ja nen Lösungsweg, wir einigen uns auf 50%...Smile OK, Spaß beiseite, wäre trotzdem gut da mal nachzuhaken

GLG

Plattform: Notebook ASUS W90vp mit Win8 Pro 64bit
Intel Core 2 Quad Q9000 Taktung normal 4x 2 GHz, bei Spielen 4x 2,7 GHz
6GB DDR2 800MHz
2 x ATI HD 4870
2 x 500GB HDD als RAID Verbund
Reply
#21
Ich glaube, dass dies schon so richtig ist. Kleine Info am Rande dazu: Die Grundsätzliche Idee war, dass bei einer gut befestigten Stadt 3 Angriffe von sehr starken Konvois zur Übernahme notwendig sind Wink

Grüße,
Daan
Reply
#22
Ah so, na dann ist ja alles klar, dachte mir das schon...
ABER, eine Frage hätte ich da doch, warum kann ich Konvois mit 50 Linienschiffen bilden, aber nur drei Schiffe (im Stadtangriff) und eines im Piratenangriff benutzen? Ich weiß man kann es niemanden Recht machen, aber würde sich das nicht besser spielen lassen? Zumal ja im Konvoi mit sagen wir mal 20 Linienschiffen nur 3 davon als Kampfschiffe gelten, finde das irgendwie nicht so passend, daß im Falle eines Angriffes nur 3 kämpfen und die Anderen zuschauen und wenn die 3 verlieren sind die anderen 17 ja auch weg... Also wenn das anders wäre, PERFEKT...!!!Big Grin

GlG
Reply
#23
Verständliche Frage Smile Die Erklärung liegt aber auch auf der Hand: Stell dir vor dein Rechner hätte gerade mal die minimalen Systemanforderungen erfüllt und nun soll eine Seeschlacht (für den Fall Multiplayer) mit 50 Schiffen gegen 50 Schiffe durchgeführt werden (Nur die wenigsten werden wohl 50 Schiffe in einer Schlacht manuell steuern... ^^) ... In den Städten kommt noch zusätzlich ein weiteres Problem hinzu: Die Anfahrten und Anlegepunkte werden intern fest gesetzt. Klar hätte man an dieser Stelle auch anders konzipieren können, aber dann wäre mit massiven Performance-Einbußen und Problemen in der Übersicht zu rechnen gewesen. Zumal die Vorgänger auch immer eine Beschränkung der Geleitschiffe aufwiesen, fiel die Entscheidung (zur derzeitigen Handhabung) halt zu Gunsten von Performance und Übersicht.

Grüße,
Daan
Reply
#24
Als Programmierer würde ich sagen, ich verstehe das, als Spieler denkt man da natürlich eher an den Spielspaß. Vielleicht hätte man in den Voreinstellungen das System ermitteln und daran dann die Programmierung also das PlayGame anpassen können, so zB schwacher Rechner Performance so wie jetzt, stärkere Rechner individuell einstellbar bis vielleicht 10 oder doch mehr Schiffe...
Ich weiß, das Wunschdenken eines Spielers...Smile
Trotzdem Danke für diese Konversation...

GlG
Reply
#25
Hallo,

bei meiner Version 1.3.2-2941 1 BS wird in der Stadtinfo beim "I" der Status Anzeige nur ein ?unbekannt? eingeblendet.

MfG
Heinz
Reply
#26
(21-12-2012, 11:43 AM)r-kane Wrote: Seit dem Build 29411 werden die Auftragsinformationen wieder richtig angezeigt. Gute Arbeit! Smile

Hallo r-kane,

Vielleicht ist das eine blöde Frage, aber worauf bezieht sich "Build 29411"?. Heisst das, wenn ich heute mein PR3 wieder einmal starten würde, bekomme ich ein Update und alles läuft wieder wie gewünscht?

Gruss

PS: Ja, ich weiss, kurz PR3 starten und ich wüsste es! Mein Game-PC liegt aber im Keller und wird nur selten gestartet...
Reply
#27
im Hauptmenu ist in der unteren (linken?) Ecke die Versionsnummer und dort würdest Du auch den "Build" finden.

müsste so aussehen: Version 1.3.2-29411 BS
Lebe jeden Tag, als wäre es Dein Letzter! / Live each day as it would be your last!
[Image: http://imghost4you.com/images/46.png]
Reply




Users browsing this thread: 1 Guest(s)