Port Royale 3 - Bug Reports Thread (Version 1.3 only!)
#1
Port Royale 3 - Bug Reports Thread (Version 1.3 only!)

Please use this thread to report gameplay bugs you encounter with Port Royale 3 updated to version 1.3 only!

For Crash reports and technical bugs: Thread

changelogs:
Version 1.1
Version 1.1.2
Version 1.1.3
Version 1.1.4
Version 1.2
Version 1.3
Ehrenamtlicher / Voluntary Moderator
Ich bin im Forum rein ehrenamtlich tätig. Mein Posting spiegelt nicht zwingend die Meinung von Kalypso Media wider.
I'm acting as moderator on a voluntary basis. My posting does not necessarily represent Kalypso Media positions.
Reply
#2
Just got the update and now the game wont start. The Kalypso launcher version on my system is different than the game version. Is there an update for the launcher? Is that a compatability problem? Been playing since the release, and through all of the other patches with no problems.

Edit
Fixed it by renaming the Profile.cfg file and running the Steam Defrag. Thanks to Falko!
Reply
#3
OK, Played thru all updates until today. Downloaded the new update from the game screen continue prompt ( took over an hour) and now it doesn't work. Grey screen and message in the middle opened window : Port Royal 3 has stopped working. What do I do now?
Previous post talked about changing something in the launcher. I have no idea how or what to change or where that is done!!Big Grin

Well, phooey! Can't even play the great v1.2 game I had going!! Don't know about others, but I'm using Win 7 on a PC. All other patches were loaded from Kalypso game start screen. I had no issues except having to play in Windowed mode like others. Reputation / Stock down on Kalypso after tonight! Hope when they get to work on the other side of the world someone figures out how to fix this. I get very few hours to play games, and I'm dissappointed about this. Sounds like a good patch though. SadSadSad
Reply
#4
(17-10-2012, 12:13 AM)howie099 Wrote: I just bought the update it loaded and that loaded a very small patch about 300K and now the program won't load. I get a grey screen and is just tells me Port Royal 3 stopped working. Where is the profile.cfg file?

Renaming the proflie.cfg doesn't help.
Make really sure you have your game "key" before you start.


Find APPDATA (type %APPDATA% in to the run command line)
You may need to deselect the HIDDEN Atribute on APPDATA - Right and select properties - untick HIDDEN

Check that the Properties on the KALYPSO MEDIA FOLDER - have READ ONLY deselected as well.
Open the KALYPSO MEDIA FOLDER\PORT ROYALE 3 folder
MOVE or COPY then delete
SAVEGAME ; TRADEROUTE folders to someplace in MY DOCUMENTS
MOVE or COPY then delete
PROFILE.CFG & OPTIONS.CFG

Run the game - it will ask for the game Key (make sure you have it) - it should recreate your profile - and do any updating required. If you run OK your can copy back TRADEROUTES and SAVEGAMES.

Edited to hightlight that HIDDEN & READ ONLY ATRIBUTES need to be deseleted - see screenshot

[Image: http://www.image-share.com/upload/1806/297m.jpg]
Reply
#5
I've got the same problem. My game crashes upon logging in. I never get to the main menu with this new update. Any help is appreciated.
Reply
#6
Hi!

billyplod's answer should fix your issues Wink
Otherwise, please tell me.

Best regards,
Daan
Reply
#7
Of a number of convoys controlled by the PC, on the main map is displayed as the number of force "10" when it is much greater.

EDIT: As that conveys the dock and sail from the various cities, the value is reset on the right.
Reply
#8
(17-10-2012, 09:04 AM)Daan Hugo Wrote: Hi!

billyplod's answer should fix your issues Wink
Otherwise, please tell me.

Best regards,
Daan

I have the same problem as mentioned above but with a clean install of the game and the fix dosn't help.
Reply
#9
@Nessunowin32: Sorry, but I don't get it Sad What do you mean?

@mathe: So, you are sure you deleted the profile.cfg manually before starting the game? What kind of version do you own (Steam, Boxed, ect)?
Reply
#10
@mathe
Is your game a boxed retail version or D2D (Steam) or similar?
STEAM - check you have KEEP GAME UPTO DATE selected in game properties and then VERIFY LOCAL CONTENT in Steam

REALLY Make really sure you have your game "key" before you start.
other D2D and Boxed retail. UNinstall game and check that the Port Royale 3 Folder in APPDATA is deleted. Then reinstall and run through all the patch installs.

Otherwise post what version you have and how you get to the fail point.
Reply
#11
@billyplod & Daan Hugo
I have the game from gamersgate.

I didn't seem to even have the profile.cfg file from the start.

Ill try reinstall the game and see if it somehow works

Reinstalling seems to have helped, no problems so far. Yay!
Reply
#12
I had to reinstall the game to get it to work. I did have to go to windowed mode. I'll buy the add on later today and see how that goes.
Reply
#13
(17-10-2012, 09:04 AM)Daan Hugo Wrote: Hi!

billyplod's answer should fix your issues Wink
Otherwise, please tell me.

Best regards,
Daan

I don't have a profile file in the directory. I bought my version from Amazon online and downloaded it. I guess I can try and reinstall. Seems like that worked for some people.
Reply
#14
Is the 'hidden' attribute deactivated? Are there any other files? Did you tried to reinstall the game? When exactly does the application stops working?
Reply
#15
I installed 1.3 and it didn't work. I saved my savegame file before I reinstalled it again. . Game works. I reinstalled savegames. One bug I noticed today. I am rank Ruler of the Seas on my savegame. When I go to the tavern to gamble, the bet is $4500 instead of $200000. It actually started out one level lower, then shifted to $4500. LOL Guess I don't have good credit although I have 11Million cash!!
Reply
#16
The tavern gambling amounts have been reduced, it was too easy to make loads of money very easily. An "exploit" if you save and reload you always win.
Reply
#17
Hi...

The info first for the techy folks.

Game was downloaded via the Kalypso site, fresh install since i've just bought it and never played PR 3 before.

System specs....

AMD Phenom II X4 Black Edition
8GB GSkill Ripjaw RAM
GeForce 460 V1 (1gb DDR)

Running game at 1080p (1920 x 1080) @ 60hz, graphics on Very High, AA at X8, AF at x16. Normally, the game looks fine, as can be seen here....

http://farm9.staticflickr.com/8473/81016...8120_o.jpg

However, and this happens VERY randomly, sometimes after the first few minutes, sometimes after about 2 or 3 hours playing. The seas surrounding the towns in town view turn a bright neon orange, the ships turn "see through" showing the true sea colour through them. If I go out of town view the clouds hovering over the map flicker on and off. When i go back into town view the sea and ships are back to normal, but when i go into the Architect menu, all the building images are either missing, or pure black. I tried taking a screenshot of this, but even with FRAPS if i try taking a screenshot with the game in this condition it just comes out pure black.

Dropping the graphics down to "average" or "low" the same thing still happens, but usually not instantly, only after about 2 or 3 hours of play.

I know the first thing the tech folks will say it "graphics card overheating" but I have an Arctic Accelero after market fan on this, the card never goes above 48c even playing games like Binary Domain, Mass Effect 3, Second Life, Skyrim or Metro 2033.

Sometimes (although not all the time) alt tabbing to desktop and then instantly bringing the game back up again gets rid of the issue and it wont appear again until the next time i open the game up after fully closing it.
Reply
#18
Maybe it's a matter of your graphics driver... If an update doesn't fix anything, you should post your DxDiag Wink

Best regards,
Daan
Reply
#19
@Victor1

Even using FRAPS to get a screen or video you need to be running the Game in Windowed mode.

You do need to post your DXDIAG - the Phenom II processors need a specific BIOS version on different motherboards. And with the GeForce 460 cards FSB speed was an issue.

The fact that the image recovers sometimes after an alt / tab, effectively "redrawing", reimaging the whole screen indictates a "leak" of some sort in the imaging process with this game on your system rather than an inherent issue with the game or your system.

Initially try running in Windowed Mode and if you get the problem ALT / TAB to desktop and wait 5 secs then back.
Reply
#20
ok here's the DxDiag...

DxDiag.txt

Graphics driver is up to date, bios is also up to date for this specific ASUS Republic of Gamers motherboard, I am a former dev myself, having worked in Interplay (before the first bankruptcy) and then in Activision pre Vivendi/blizzard merger...i know to keep things up to date Smile
Reply
#21
It looks like you are running on a Foxconn motherboard with an ASUS monitor connected via HDMI - have you tried using a DVI-D cable - looking at the tech specs both ends support that.

I've seen problems with HDMI connections on PCs, flickering mostly but also resolution loss.
Did running in Windowed mode help.
Reply
#22
Running in windowed mode didn't alter anything, still done it. I've done a clean sweep and uninstall of the graphics driver and the PCI-E slot drivers and a fresh install of both, didnt do a thing (apart from make Skyrim run at a few extra FPS). As for the cable, i doubt it would be that, if it was affecting this game then it would affect other games from this year which are more graphics intensive than Port Royale 3.

None of the other games i have installed (and theres a lot installed) has this strange problem. Last year there was a problem with Second Life but that was down to an inherent bug with OpenGL which was fixed at the beginning of this year, and Port Royale 3 isn't using the OpenGL engine, at least i don't think it is. The ships turning transparent when the water turned orange was reminiscent of the alpha layering bug of OpenGL based games. I tried Port Royale 2 earlier this afternoon, it ran just fine, same with Sid Meiers "Pirates!", again, ran fine. The Alt-Tab solution will have to do for now to get rid of the orange water and transparent ships...but sometimes the game ends up freezing out then crashing when i do an Alt Tab.
Reply
#23
Hi!

Please update your graphics driver Wink

Best regards,
Daan
Reply
#24
@victor1st

There is a new driver - released on 10th Oct --- > http://www.nvidia.co.uk/object/win8-win7...er-uk.html
Reply
#25
Bug discovered(PC via Steam):

In free play mode, when attacking a weakened military convoy of strength e.g. 96(shown on the little mouse-over pop-up next to the national flag), the strength will magically increase to the convoys max (e.g. 137) in the automated/manual/cancel dialog.

1) If you enter the battle(manual or automated) the strength is still elevated.

2) Even worse: If you don't enter(cancel), the strength will now also have changed in the mouse-over pop-up next to the national flag.
Reply
#26
@Leader of the World

It looks like in the 3 examples in the images below that the initial strength of the Convoy shown in the information pop-up by the "mouse over" increases to maximum at the point of attack. But a subsequent attack the strength of the convoy in the "mouse over" is the same as that at the point of attack.

All these examples are from me attacking a nation without being at war. Is this the same in your case? My only thought is that these convoys do not run at full strength until war is declared. Perhaps Daan can expand on that - or it is an "undesigned game feature"

[Image: http://www.image-share.com/upload/1856/277m.jpg]
[Image: http://www.image-share.com/upload/1856/278m.jpg]
[Image: http://www.image-share.com/upload/1856/279m.jpg]
Reply
#27
I discovered the anomaly while attacking Holland. I had a valid letter of marque

[Image: http://i48.tinypic.com/2rr5sie.jpg]
[Image: http://i46.tinypic.com/23hmuqr.jpg]
Reply
#28
@Leader of the world

Same thing I found - though with a "LoM" I would think that any Military Convoys would be at full strength.
Reply
#29
I would think other wise.

Being at war, some convoys are bound to be limbing back to port for repairs and fresh crew
Reply
#30
Hello, here is two weird things I noticed :

- When you attack a city, if you join a sea battle during that city battle, when, after the sea battle, you get back to the city battle, all animation are desynchronised with the HP of the fortress, crew numbers etc. There's also weird things, as ships that "teleports" or going reverse way.

- There must be a trouble with the Pirates DLC ranking : Right now, i'm 8th in it, but how could the 1st one achieve the goal in 0.0 days and the second one in 0.2 days ???
By the way, it would be nice to have details when clicking on a player (number of ships captured, gold stolen, max sailors etc.)
Reply




Users browsing this thread: 1 Guest(s)