Tropico 5 fails to start issue (boxed retail) - Hotfix available!
#1
Hi all,

The boxed retail versions of Tropico 5 using Kalypso Launcher have been hit by a hideous activation bug which prevents the Launcher from starting up properly.

If you're affected, please download and install a hotfix restoring Launcher functionality from this location:

http://download.kalypsomedia.com/Kalypso...Hotfix.exe

The Fix will auto-install in the correct installation folder for Tropico 5 and the Launcher will then prompt you for any other available updates.

Sorry for the inconvenience!

STEAM VERSIONS ARE UNAFFECTED! Do not attempt to install the hotfix with your Steam version of the game!
Reply
#2
It works for me - Thank you all very much for your speedy response Smile

Fantastic customer support as always Big Grin
Reply
#3
This is strange, it won't install:

Quote:Could not apply hotfix data (1)
Access to the path 'C:\Program Files (x86)\Kalypso Media\Tropico 5\AppData.exe' is denied.
Reply
#4
(18-11-2014, 04:05 PM)RedNovember1917 Wrote: This is strange, it won't install:
Navigate to the folder and then

Try - Right Clicking the hotfix.exe and "Run as Administrator"
you may be prompted for you Admin password (login password)
Reply
#5
(18-11-2014, 04:31 PM)billyplod Wrote: Navigate to the folder and then

Try - Right Clicking the hotfix.exe and "Run as Administrator"
you may be prompted for you Admin password (login password)

I have been doing that, but to no avail.
Reply
#6
Quote:Could not apply hotfix data (1)
Access to the path 'C:\Program Files (x86)\Kalypso Media\Tropico 5\AppData.exe' is denied.

Something seems to be blocking access to the installation folder or you're missing the required privileges. Make sure no third-party software is running and that the game has been properly installed to the folder mentioned in the error message.
Reply
#7
I have fixed it! Thanks for the assistance, guys!
Reply
#8
(18-11-2014, 06:06 PM)RedNovember1917 Wrote: I have fixed it! Thanks for the assistance, guys!

How did you fix it?
In case somebody else has the same problem....
Kalypso Media
Follow Kalypso on Twitter!

For game support issues please contact our support team via email support@kalypsomedia.com
Reply
#9
(18-11-2014, 06:47 PM)MT™ Wrote: How did you fix it?
In case somebody else has the same problem....

I changed the "AppData.exe" from a read-only file to a file that is neither read-only or hidden in its "Properties" panel.
Reply
#10
I don't Know if it's just me but after applying this update performance of the game suffers substantially, and every time I go to the main menu to exit the program crashes.
Before the major error, everything ran smooth as silk.

AMD FX 8350
16GB 1866mhz ram
XFX R7 250 4GB
Windows 8.1 Pro

Retail Tropico 5
Reply
#11
Heya Timo,
The game works now and seems to be running smoothly and with no dramas.
Thanks for the really quick turnaround on the patch!
Much appreciated!
Reply
#12
(19-11-2014, 10:36 PM)me@djjaybird.com Wrote: I don't Know if it's just me but after applying this update performance of the game suffers substantially, and every time I go to the main menu to exit the program crashes.
Before the major error, everything ran smooth as silk.

Make sure the Launcher is downloading and installing the latest update (1.06). The hotfix affects the Launcher only, there are no changes to the game code whatsoever. If you've been playing 1.06 before, your experience should be unchanged.

If the errors persist, you may want to try a fresh install.
Reply
#13
(18-11-2014, 06:54 PM)RedNovember1917 Wrote: I changed the "AppData.exe" from a read-only file to a file that is neither read-only or hidden in its "Properties" panel.

I tried this and I still cant get the Hotfix to work. I just keep getting the access denied. I tried running as an admin and also unblocked the program in the properties. I even re-installed the whole program. Any ideas?
Reply
#14
(20-11-2014, 02:42 PM)mattcdm Wrote: I tried this and I still cant get the Hotfix to work. I just keep getting the access denied. I tried running as an admin and also unblocked the program in the properties. I even re-installed the whole program. Any ideas?

Did the game work before on your system?
Kalypso Media
Follow Kalypso on Twitter!

For game support issues please contact our support team via email support@kalypsomedia.com
Reply
#15
(20-11-2014, 03:39 PM)MT™ Wrote: Did the game work before on your system?

Yes- I was enjoying the game for about a week when all the sudden (Monday for me) I couldn't launch the game again. I have tried everything i can think of to get it to work again since.
Reply
#16
(20-11-2014, 03:43 PM)mattcdm Wrote: Yes- I was enjoying the game for about a week when all the sudden (Monday for me) I couldn't launch the game again. I have tried everything i can think of to get it to work again since.

I finally got the Hotfix to work!!!! Looking deep in my system i found that one of the previously downloaded/installed versions of the game didnt completely uninstall properly. I got rid of that, and absolutely anything Tropico related on my PC. Re-downloaded and installed the game, changed all the protections (as discussed above) and then the Hotfix worked. Disappointed that i had to go thru this for sure, but very happy that the game is loading once again.
Reply
#17
Thanks for sharing your solution!
Kalypso Media
Follow Kalypso on Twitter!

For game support issues please contact our support team via email support@kalypsomedia.com
Reply
#18
Can't launch the game (pre-order version - same as the boxed version?) or apply the hotfix above. I think its a Nvidea issue and not Tropico though, since the problem seems to have started at the same time as the last GPU driver update, and most people reporting launch problems seem to also have Nvidea cards. Not sure how to fix it....

Win7 64-bit version
Geforce GTX 660M graphics card
- Geforce Driver 344.75
- Release date 11/18/2014
Reply
#19
@max1313
Most of the posts with video problems seem to have cards that don't support DX11.

Your video card does support DX11 - the driver is the latest version.
Have a look at this Post and try the options

http://forum.kalypsomedia.com/showthread...#pid202158

failing that do you get an error message. Also you are using a laptop, so post your DXDiag here:- (laptops tend to use shared memory which doesn't help and slightly different drivers).

+++++++++++++++++++++++++++++++++++++
To Run DXDIAG
Click on START
Select RUN (This opens the RUN dialogue box)
TYPE - "dxdiag" - Click OK

This opens the DirectX diagnostic tool
Click on "Save All Information" - when the SAVE box opens save to a "name.txt" file
When you post the file use the Preview Post option and select "#" symbol - cut and paste the contents of name.txt file after the "#"
then click on the "Close Tags" that appears at the top of Message window.
That way you post inside a scrolling window - makes it easier to read.
+++++++++++++++++++++++++++++++++++++++++++++++++++
And the screen shot of you error message.
Reply
#20
(24-11-2014, 01:03 AM)billyplod Wrote: @max1313
Most of the posts with video problems seem to have cards that don't support DX11.

Your video card does support DX11 - the driver is the latest version.
Have a look at this Post and try the options

http://forum.kalypsomedia.com/showthread...#pid202158

failing that do you get an error message. Also you are using a laptop, so post your DXDiag here:- (laptops tend to use shared memory which doesn't help and slightly different drivers).

@billyplod
Thanks for the suggestions. I checked the 'dxdiag' and 'sfc /scannow' and both report no errors. My card has separate memory and runs every game I try no problems, and worked fine with Tropico before.

The issue started the same day as the Nvidea driver update, which is also the same day as many other users with Nvidea cards reporting the same launch problem, which makes me think its the new driver. Plus, there were no new updates to Tropico (v1.06) so its probably not the game.

I'm just going to wait and see if they update the driver again soon, (there's been 2-3 updates recently), and hope they fix it; or else I'll try rolling my driver back to the previous version that was compatible.
Reply
#21
I'd try rolling back the driver. See if that works.

Truth - I always stay one release behind on drivers - unless I have an actual problem. Let the other guy test it.
Reply
#22
(06-12-2014, 04:26 AM)Coach Ryan Wrote: Hi,

I recently purchased this game for my son to enjoy. I installed the game once, and instead of launching... it prompts me to re-install the game over and over and over again. I am no tech guru by any stretch of the imagination, but I presume each installation is "successful" (there aren't any error messages or anything of that sort after each installation). Has anyone else encountered this issue? My computer operates off of Windows 8, for the record.

Thank you and God Bless,
-Coach R.

Sorry to hear that you're having trouble enjoying the game. How exactly are you launching the game once installation has finished? There should be a desktop shortcut or Start menu entry for Tropico 5.
Reply
#23
ty I just got the game today 12/9/14 it installed fine on windows 8.1 but wouldn't open then installed it again and and found this post wale wating for it and now it seems to be working
Reply
#24
Purchased the game on Day-1, and run into the issue that hte launcher could not get updated. Kalypso never came with a solution for this. Sad So been ignoring this issue all together and been playing the game ever since.

Haven't played the game for a few weeks and now today it fails to launch completely. Double clicked the Tropico 5 icon and nothing happens Sad

I tried the hotfix, but all I get is an error trying to install it.

The error is: Could not apply hotfic data (1), Access denied to the path C:\Games\Tropico 5\AppData.exe

I tried to run the fix as administrator, no luck
I uninstalled the Game, re-installed, it would not launch
Tried to apply the patch, same error message

I am running Windows 8.1 btw.

Please provide me with a fix and don't point my in circles like with the launcher problem I have been facing from day-1...
Reply
#25
(18-11-2014, 06:54 PM)RedNovember1917 Wrote: I changed the "AppData.exe" from a read-only file to a file that is neither read-only or hidden in its "Properties" panel.


Thanks RedNovember, your fix solved both my day-1 problem and the hitfix problem!!! Big Grin

Seems all files are set to read only for some reason... Removed the read only setting and the hotfix installed and also the launcher got updated successfully!

@Time, why in earths name does it set all files to read only?
Reply
#26
probably the reason is Windows and not T5 in this case...
Lebe jeden Tag, als wäre es Dein Letzter! / Live each day as it would be your last!
[Image: http://imghost4you.com/images/46.png]
Reply
#27
How can I download Kalypso Launcher?
Reply
#28
You don't download Kalypso Launcher. It's integrated with the game.
Reply
#29
But I can't run the game. The fix is not compatible with Windows 8.1.
Reply
#30
I'm having a problem with Net Framework. Help me please.
Reply




Users browsing this thread: 1 Guest(s)