P4 dimming screen problem
I installed p4 and p4 rise of a dynasty today and while playing p4road (for some reason after installing this my p4 doesn't work, i don't care anyways but i can't confirm if the problem persist in p4 as well) i find myself having a problem in which the window screen in most of the cities is dimmed, it's like it's dark like night, but the game has no night as long as i know. And the problem seems to be related to the clouds. And , if i disable cloud shadows it wouldn't fix the problem. When it's enabled it seems like the clouds and the sky are swapped meaning the cloud shadows should be dark while they are bright and instead the whole area is dark, it's a little hard to explain so here come the screen shots.

It's really annoying and i can't keep playing like this... The frequency of this bug appearing is so high (it happens most of the time i enter cities) and it's related to alt+tab as well, since when i do it, this condition can be changed sometimes( for better or worse).

My graphics card is Geforce GT 750M 2GB and i have tried the solution provided in this topic http://forum.kalypsomedia.com/showthread.php?tid=28629 which didn't work. ( i don't have that option in the nvidia settings)

Btw im playing this on a late 2013 macbook pro on bootcamp (which means windows) and it's windows 8.1.
I play a lot of games on bootcamp and never have i had any problems at all. (the drivers are uptodate to the latest firmwares provided by apple) The windows is up to date as well.

All of the graphics options are on the highest and i only play with Clouds Shadow in these screenshots. I have tried to change all the setting and i haven't been successful. Restarting the game or the computer haven't fixed the problem either.

Problematic + clouds ON: http://imgur.com/VGQGdS4
Normal + cloud ON: http://imgur.com/RhfQ9WL
Problematic + clouds OFF: http://imgur.com/ZGrGnCM
Normal + clouds OFF: http://imgur.com/3MxiqS5
One of the problems with 'Bootcamp' is that you can’t install drivers for your video card or chipset from Intel, AMD or Nvidia, so you won’t get any performance updates that come with new driver releases unless Apple releases with new Boot Camp.

First are you at the latest Bootcamp version?

It's an emulator so you need to make sure thta you adjust the resolution and detail settings for performance that matches the hardware you have.

Second set all Video options to minimum and work up.

It's an emulator so you are stuck with what it provides so

Third check the Forum:-
There are discussions on driver updates.

There are other emulators available: - Wineskin; VM ware; Vitualbox; Parallels - but these are all emulators and the performance is only going to as good as the emulator.
Thank you for your response billyplod, hanging around the forum i found out you're keeping this whole universe alive by yourself Smile That's very much appreciated.

Well, actually there is a newer version of bootcamp software available that has been released recently i'm gonna download it and try.

Yes bootcamp has it's own problems but coming to think of it, i have never had any problems with games so i doubt that it's a bootcamp problem, on the other hand i'm a little bit suspicious of the graphic card, i wish i knew if there was some settings i could tweak to see what happens. (i already tried nvidia settings, all of it's different settings and it didn't make a difference, i guess since the game doesn't use the 3D feature, me just tweaking with the 3D settings wouldn't work after all anyways.)

I did actually try all the settings in the graphics section in the option of p4 but none of them seemed to make any difference. The cloud shadows are strange, i don't know why they are swapped with the sky (or sunlight?) it's like the sky has become a big cloud with holes in it. I really think it's a graphic card problem, an incompatibility if you will. I wish i knew if someone with a PC and this card had the same problem.

Yes as you already know those emulator are for everyday work and not playing games so i'm not even gonna bother trying this on my Parallels windows 7.

For now i guess i have to try updating bootcamp, which i think won't make much difference anyways. But thank you for your effort, i try to keep this topic updated if i can with your help, maybe in the future someone runs in the same problem Wink

Users browsing this thread: 1 Guest(s)