Problem with updating game
I bought Tropico 5 retail edit, when i run launcher i can only log in to kalypso, and then click play tropico, no updates, i was trying to run as admin, also turn off firewall, nothing helps, im running 1.09 game version and launcher. can someone tell me how can i update my game ?
I have the same problem as the user above me. I was trying to run hotfixes, adding an exception to the firewall, but none of this helped.
I have exactly same problem, retail version, when trying to play with friend who has steam version. He has version of launcher and 1.10 game version, me respectively and 1.09. My launcher always skip update as if he running in offline mode.
have you tried this:
Lebe jeden Tag, als wäre es Dein Letzter! / Live each day as it would be your last!
Hello everybody.
Have you tried uninstalling and reinstalling the game?
As we cannot reproduce this problem anyhow and always downloading and updating to the latest version, which is 1.10.

After you have installed Tropico 5, please check your internet settings as well as any respective anti-virus software and/or firewall/s if you have full administrative access as well as both the Kalypso launcher and Tropico 5 itself is not restricted of any kind when trying to access the internet.


My friends and I have a very similar problem. They have retail versions of the game and have versions of the launcher and 1.09 of the game, while I have and 1.10 on Steam so we can't play together. They cannot update, I cannot downgrade. It actually seems like it's much more common because they say they have a lot more people in their multiplayer lobby than I do. 
Looks like that retail non-steam versions don't update to 1.10.
Hello BattulBruvaCat.
You actually do not need the Kalypso-Launcher, when owning the Steam version. This is totally optional and has totally no effect on users of the Kalypso-launcher. Means, even you might have for any reason another Kalypso-launcher version than your freinds that actually need the Kalypso-launcher, due to them owning the physical copy of the game, this will not hinder you to play with them.
Nevertheless question here is, why they cannot update their game's version to 1.10. But as I have stated, there is no problem at all with the Kalypso-launcher (version), as I have tested downloading and installing (digitally and from retail) both with the same effect, of me also being able to update the game to the latest version.

So please tell your friends to completely uninstall and reodnload and reinstall the game.
If nothing will help, they should contact our support directly:
with all details they can provide about their current problem. Additionally they should add on which platform they are playing and from which format, like e.g. retail-copy of Tropico 5, as well as their system specs.


nothing helps, i`ve re-installed whole game, trying this hotfix, im in contact with support. already tried their 1st advice, also that didnt helped..
there is any way to update game manually ? just download patch from anywhere and install it ?
The same applies to my problem. I've tried all this hotfix stuff and also gave all admin priviliges needed. Still, nothing happens.
Launcher ver. is still and game ver. 1.09
If you have a partially installed update or one that has failed then to tidy up to allow a clean install try MS FIXIT.

Users browsing this thread: 1 Guest(s)