Tropico 5 freezing after a few minutes of play Xbox 360
On Saturday after not playing Tropico 5 for about a year I wanted to start playing the game again.  I have the game on disc for my xbox 360 and had played it last year with no problems.  Before trying to play I purchased two pieces of additional content from the xbox live store and downloaded them.  When I started to run the game, my xbox 360 informed me there was a game update that needed to be installed and so I let that install.  Then I created a new dynasty and started a new sandbox game. 

When I was creating a dynasty, after I had finished creating my character before the game switched over to the select map screen it froze on the loading screen and I had to power off my xbox.  I restarted the xbox 360 and the game, found the dynasty I created and selected a map.  After only a couple of minutes on the map, while I was looking at the crop suitability for starting some farms the game froze.  and I had to power off the xbox and restart.  I selected the same dynasty and same map several times and this happened repeatedly.  I tried selecting a different map and it still happened.  The game would freeze after just a couple minutes of play. 

I tried deleting the game update and then starting, but it wouldn't let me use my dynasty because of the downloaded content.  When I tried creating a new dynasty I did not have access to any of the new maps, campaigns, or buildings.  It said that the downloaded content required the update

I tried letting my xbox install the game update again but then the game froze after just a couple minutes of gameplay.

I see there is another thread on the forums from a couple months ago regarding a similar problem and the game update.  Are you looking at a new game update that will correct the problem this previous update caused or a way to roll back to a previous update?

I have an Xbox 360
the retail version of the game on disc
I live in the United States
my console language is set to English
the version of the game is 1.10
I have the following DLC:  big cheese, hostile takeover, waterborne, and espionage.

I have sent an e-mail to support about this problem.
Any possible solutions for the game crashing with DLC on 360?
This is a serious problem.
Has there been any resolution to this problem? I tried to play yesterday and the game froze again after only a couple minutes of gameplay.

Is it a specific expansion with the update that is causing the problem? Or is it the update no matter what expansions a person has?

Users browsing this thread: 1 Guest(s)