Xbox one resists not showing
#1
I play the PS4 version from Day One and I faced the following issues/bugs/requests so far:

1) Bug: The "Gold Standard Trader" trophy is glitched. It doesnt unlock.
2) Bug: The text that is displayed on the corners of my TV, is cut off (eg the objectives). There should be an option to resize the effective area of the screen.
3) Request: There should be a log/counter on which challenges have been already completed on each map, so that when I replay them, I can easily see what remains to be completed.
4) Request: There should be an option to un-socket runes... Or to keep them automatically when i dismantle the item that has them.
Reply
#2
*Platform: PS4
*Version: 1.01

Love the game so far. I'm having a really good time. Everyone involved did a fantastic job.

I just ran an Ettin Hunt on the Utgard map and about halfway through the map, there's this circular area you enter, where you have to fight two of those very large, female Jotuns. Well, after I killed both of them, I proceeded to the little rock bridge that connects to the next area of the map, and found myself hitting an invisible wall.

I assume the invisible wall is only supposed to be there during the fight, but it didn't disappear after the Jotuns were defeated, and I eventually just had to teleport back to home base. The invisible wall was not there during the story mission that took place on that map, only during the Ettin hunt that I attempted much later.

Thanks for all the hard work on bug-squashing. It's much appreciated. Smile
Reply
#3
*Platform: PS4
*Version: 1.01

While conducting a 'Knight Hunt' on - I think, 'Castra Ignis,' I might be wrong - the treasure chest that can be opened after you cut the rope on the shore and watch it float downstream, still drops 'a rusty key' as loot on post-story hunts, even though the room it opens no longer needs to be unlocked.

Also, I've noticed that when enemies die instantly as a result of 'Slay Chance' they simply drop dead to the ground without so much as a weapon strike sound effect. Maybe this is intended, but it seems odd to me, and it feels like something more dramatic should occur.

Also, I've noticed that when playing as the shield-maiden, on some helmets her pony-tail still shows dangling at the back of the helmet and on some of them, it doesn't; even on short helmets where seeing the pony-tail would be appropriate. Instead, on some helmets she's just left with an odd-looking bald spot on the back of her neck. I noticed this particularly on low-level heavy helmets, when worn with the hairstyle that leaves both sides of her head shaved, a strip of hair down the middle of her scalp, and a pony-tail down the back of the neck.

Also, when testing a male character with a two-handed axe, I noticed that the weapon strike animation that occurs when the hero leaps a short distance at the beginning of combat, seems to glitch slightly and the weapon animation looks like it skips a few frames on striking.

As a side-note, I really enjoy this game. The variety of environments and the beauty of their design continues to amaze me. I really hope this game is successful enough to warrant some DLC or expansions. Smile
Reply
#4
As more players joining our awesome community, even when coming from the realms of the PlayStation 4 and XBox One, we have created this thread, where we collect all bug- and problem reports for XBox One and PlayStation 4

If it comes to problems on your console, please have a look into the XB1 + PS4 technical FAQ:
http://forum.kalypsomedia.com/showthread.php?tid=29569

You can also contact our technical support, if you are having any technical issues:
support@kalypsomedia.com
Reply
#5
On PS4, even though my game is updated to 1.01, the flag counter still resets in "Old Enemy."  I even tried deleting the game and reinstalling; didn't work.
Reply
#6
(16-04-2017, 06:42 AM)viking_warrior Wrote: On PS4, even though my game is updated to 1.01, the flag counter still resets in "Old Enemy."  I even tried deleting the game and reinstalling; didn't work.

I have the same problem. And it seems to be on both PS4 and Xbox One. I normally play on PS4, but I recently picked up the digital copy of Vikings for Xbox One as well, and this glitch happened on both versions of the game for me.
Reply
#7
I am on xbox one and when I leveled up I have placed a point 4 times into Elemental resist and it is showing nothing on my character statistic page?
Is this a bug or what? Please let me know if this is an issue and if it is known to happen.

Thank you.
Reply




Users browsing this thread: 1 Guest(s)