Patrician IV Bug Reports Thread (Version 1.3 only!)
It should state the version at the bottom righthand corner of the game.
Reply
Dear Gabriel74sj,

ensure your PC has an internet connection and the game will update automaticly when starting the launcher. There is no 'special' patch for a spanish version and there are no 'stand-alone' patches. So, you will not be able to download any patch by yourself.

Kind regards,
Daan
Isn't PIV (ESP-Version) released as 1.3? Did you mixed up the version no. of the launcher and the game? Did you used any illegal files?
Reply
(28-07-2011, 11:09 AM)Daan Hugo Wrote:
(28-07-2011, 12:52 AM)Snootch Wrote: 1.5) The mod tools do not work for the American boxed version of Patrician IV

Hi!
That is definitely not correct.
Kind regards,

Daan



Definitely IS correct.

Reply
(30-08-2011, 06:34 AM)Snootch Wrote: Definitely IS correct.

If you are refering to the Patrician IV version without the add-on(!) you are right, but with the expansion (RoaD) it will work 100% correctly!
You are able to mod your game if you have a version including RoaD.
Besides, this is not a bug. European players without the expansion aren't able to mod too.

Furthermore, modding is a special service provided by us (GMinds) additional to your product. So, I think it is kind of unfair blame Kalypso or us if you're not able to mod your game.

I wrote to you in the 'Modding'-thread:
(08-08-2011, 03:55 PM)Daan Hugo Wrote: Sorry guys, but I tested it a lot and currently there is no way to mod PIV without the add on. I'll try to find a way, but I can't promise anything...
In addition, I think I've seen a RoaD-Version available in the U.S. on the internet...

Kind regards, Daan
Reply
(30-08-2011, 10:59 AM)Daan Hugo Wrote: Besides, this is not a bug. European players without the expansion aren't able to mod too.

I apologize. After your explanation, I see that not being able to modify the base game is not really a bug. But admit it: we both didn't know that this was the case until further testing proved it. Wink

I do, however, fully disagree with the point of view that modding is a "bonus" to the game. My expectation for modability had me thinking that there was a bug when I couldn't modify the game, but I now see that this is really just a philosophical difference. (Map editors used to be standard offerings with games belonging to this genre, such as with Patrician III, for example. It looks like times are changing, and consumers like me need to do more research now.)

In my ignorance, I thought there was something wrong with the program. In my education on the matter, I now see that there is something wrong with the philosophy behind enabling people to modify their games only with further expenditures. So that is now for a different thread and not this one. Wink

Be well, Daan, and thanks for clearing this up.


Snootch
Reply
there is nothing to apologize for...i would also expect, that modding/editing would inlcude both versions.
But in this case there are deep changes in the program code between basic game and addon (town maps, ...). So the developers hds to decide, for which version modding will be enabled. with this background i would say it was the right decision, to make the addon moddable...
Lebe jeden Tag, als wäre es Dein Letzter! / Live each day as it would be your last!
[Image: http://imghost4you.com/images/46.png]
Reply
(17-12-2010, 04:09 PM)Gnida Wrote: Not sure if this is a bug - this is a situation. In Lubect architect shows that 20 wood is missing (for building a salter) and shipyard shows that 60 wood missing (for building a ship). So I bring 100 wood to Lubeck, sell it manually. A day passes - the sold wood disappers from the market but nothing changes - still 20 wood needed by the architect and 60 wood by the shipyard.

Yes it is a very annoying situation, that I am currently struggeling with too. And why can't they take it from my own warehouse storage? I have build up a huge stock of wood, brick and many other basic building materials, but whenever the market in the city is empty, they stop building!

Is there someway you can tell them to take from your own stock?

extra personal info:
I have lost 40.000 gold, because two production facilities wasn't finished at the assignment date, due to building stop. Twice! It is very frustrating, whne you have plenty in your own storehouse. I have tried to fix the situation, by selling both small and large quantities to the market, but nothing seems to solve the situation. Finally, after many ingame-days, they took up building again, but the market was still starving from building materials! I wonder how it was triggered?!
Reply
The dev's have decided that taking goods from your own warehouse is "unnatural", so that option isn't available. Which leads to the problem that the markett hall is empty when you need to build something.

Best thing to do is to make sure you have enough goods in stock, then sell them to the city (and sell more, because the AI uses the goods too) until your "projects" are done.

So it's not a bug, it's a feature. It's just bugging a lot of players though. Wink


Thorin Smile
Hack seinen Kopf ab. Ich brauche einen Aschenbecher!
Reply
its not that hard
look what the normal demand for wood/bricks per 10 days and add the demand of the building materials that should be inthe markethall
dont sell A LOT to the market hall at once!
1. you loose money if you sell 3000 wood at once
2. the AI buys the cheap stuff and you have to deliver more
=> have enough in the counting house and use the administrator to always sell wood/bricks to normal prices
(yes i know you support the AI that way .. i can live with that because the AI supports me in towns where you dont deliver (enough) wood/bricks )
Reply
@Thorin
Thank you for your help on this problem (yes I will continue to see it as a problem).

How do you ensure, that you can buy your own goods from the market then, before the computer? It seems as if the AI will always have priority as "first buyer".

(grunt grunt :-( Its weird to sell to your enemy, just for a chance to buy your own good back again at market price. Yes it is too weird for me grasp the dev's policies on this. weird weird weird...)


@Falko
Yes i thought the same. It would be the most logical solution. Except it didn't work in my situation. I have the suspicion, that foreign ships and merchants bought the market dry of anything flowing into it (wood, bricks, etc.). It seems as if the AI has first priority in anything. It makes it unfair competition and not very realistic.

I have many bad experiences with the administrators. Sometimes they don't buy or sell what they should (and it is not of lacking possibilities on their behalf). I must get better acquainted with them, but right now I don,t dare leaving much to their discretion.





NEW BUG (TRADEROUTE BUG)
I find it a bug, that when designing traderoutes, it is very difficult to rearrange the order of travel, so to speak.

detail:
When you use the graphical map you have to retrace everything, whenever you makes a mistake or wants a different bend of the route in the middle of a larger route. And the destinations you rearrange got ripped of their tradeinfo. Very frustrating.

I might have come up whit a possible solution, but I cant make sense of it at the moment. Here goes: In the tradeinfo screen (opposed to the graphical map editor), you can rearrange the destinations as you wish and without losing any info that you programmed. But still after rearragning, I am not entirely sure how the game interprets the city-order, when the convoy embarks on the traderoute. It works a bit weird.
Reply
the resorting of the destinations in the tradeinfo screen is somewhat problematic
if you move the mouse while clicking on a destination P4 seems to think you want to sort that destination but since you only "moved" 1-2 pixel P4 puts the destination on the start
Reply
(08-10-2011, 06:49 PM)PeteL900 Wrote: Hi to everyone, just joined because I've found a serious game play bug!
When battling pirates in manuel mode, the ships display Red: for Health,
Blue: for Men, and White: for Sail. Now, if you use grape shot, and wipe the men out, the pirates still fire at you!!!!! Also, if you take out their sails, they only go a little bit slower!! Will this be rectified in a future patch?

This is not a "bug" - it may be an "undesigned game feature" - but it is how sea battles are - unrealistic maybe? Check out this thread for the pros and cons

http://forum.kalypsomedia.com/showthread.php?tid=9049
Reply
(04-04-2011, 01:17 PM)Bagaluth Wrote: @heytricia
please post a dxdiag log of your system. But please contain the dxdiag log in a # box, so the post will not be so long.

THX

Hein

Um, what is a dxdiag log? Sorry, but I'm not really familiar with these things. Sad
Reply
Click on START
Select RUN (This opens the RUN dialogue box)
TYPE - "dxdiag" - Click OK

This opens the DirectX diagnostic tool
Click on "Save All Information" - when the SAVE box opens save to a name.txt file

When you post the file use the Preview Post option and select "#" symbol - cut and paste the name.txt file after the "#"
then click on the "Close Tags" that appears at the top of Message window.

Reply
I successfully patched the game sometime in December 2011 up to 1.3. Problem is: I just saw that the picture on both the disc and the package is totally different from the one showing on this forum's main web page of the game. Runs fine though.

Second problem: How come, when you get to play onto the free play's customizable game play that, the normal setting acts up like as if your at Patrician level already? I mean that my AI competitors are already at Grand Merchant and one already elected Mayor of my starting City. Plus, that there are no means to build a Sawmill for the very main resource needed for building houses, ships and, businesses of all kinds. Masons and masonry should have their bricks making factory also, right?

Third problem: Can not make any trade routes at all at the very start of the game and, the new Captain can not supply himself with his own crewmen(sailors). Why is that? Plus, even though I already have my starting Counting House, the upper right window tells me that I do not have one(0). It feels like everybody else has a huge start advantage on me and, by seeing the trading ships coming in and going without selling our City any goods what-so-ever. My first ever assignment was to gather a huge amount of refugees of about 300+ to send anywhere else than this one. The City had a mere 25% happiness. I did not have this kind of Gold for buying a Cog for such a trip.

Fourth problem: My machine might be too advanced for such aging game. Triple Core with video and sound drivers in Early Winter 2011-12 and, using Windows 7 x64 Service Pack 1 + way more updates and upgrades. Do you think the expansion would fix all of these compatibility issues? BTW: I never bothered to play the Campaign before playing the squirmish map mode, sorry.
Reply
Hi guys,

I have a terrible crash everytime when an event pops-up; events like: becoming a mayor, getting married, plague, pirates getting stronger etc.
I have the latest patch 1.3 and a retail version; i updated my graphic drivers, my direct x, everything i updated for this crash to go away but still i cannot get rid of it! My system is also on 64 bits, 6 GB Ram, 2 GB Ram for Graphic card, I5 processor, windows 7 ultimate. The error i get is something like this:

Can anyone help me? Please.

"Description:
A problem caused this program to stop interacting with Windows.

Problem signature:
Problem Event Name: AppHangB1
Application Name: Patrician4.exe
Application Version: 1.3.0.0
Application Timestamp: 4d09d2d9
Hang Signature: 48a3
Hang Type: 2304
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1048
Additional Hang Signature 1: 48a36a8c2afc2cce9bfbaa174810304f
Additional Hang Signature 2: 5614
Additional Hang Signature 3: 561460fe0c6b9579eea5d65b7458a831
Additional Hang Signature 4: 48a3
Additional Hang Signature 5: 48a36a8c2afc2cce9bfbaa174810304f
Additional Hang Signature 6: 5614
Additional Hang Signature 7: 561460fe0c6b9579eea5d65b7458a831

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=1...cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt"
Reply
@nemeiah

DO you have 3D enable on your graphics driver? - it should be set off or let application decide. The game does not support 3D and the issue happens when a pop up is being displayed.
Then you could try running the game in compatibility mode.

If that fails the post your DXDIAG here in '#' so that it scrolls and send it Kalyspo support.
Reply
Yes I do, I did manage those settings and I can see an improvement. But still it crashes some time. Maybe it's just my laptop too advanced for this game....anyway I still love it.

Thanks for your quick reply.
Reply
My game crashes every two hours. Here is the event data. My system is windows 7 sp1 64bit

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2013-02-16T13:58:13.000000000Z" />
<EventRecordID>2642</EventRecordID>
<Channel>Application</Channel>
<Computer>danai</Computer>
<Security />
</System>
<EventData>
<Data>Patrician4.exe</Data>
<Data>1.3.0.0</Data>
<Data>4d09d1ba</Data>
<Data>Patrician4.exe</Data>
<Data>1.3.0.0</Data>
<Data>4d09d1ba</Data>
<Data>c0000005</Data>
<Data>00068443</Data>
<Data>ef0</Data>
<Data>01ce0c4294576322</Data>
<Data>F:\SteamLibrary\steamapps\common\Patrician IV\Patrician4.exe</Data>
<Data>F:\SteamLibrary\steamapps\common\Patrician IV\Patrician4.exe</Data>
<Data>e6ead254-7840-11e2-b6fa-6c626d39f101</Data>
</EventData>
</Event>
Reply
First if you go through the standard stuff:-

Run Windows Update - and apply all the "High Priority" fixes
Run Windows Update - and apply any Optional Hardware fixes
Ensure your graphics drivers are up to date - Check your manufacturer’s web site
Ensure your sound card drivers are up to date - Check your manufacturer’s web site
Check your PC manufacturer’s web site for firmware updates

If you are still getting problems or crashes - then post your DXDIAG here - in tags #/# with any error message AND send it with a brief description to KALYPSO support. Then you have 2 chances to get help.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
To Run DXDIAG
Click on START
Select RUN (This opens the RUN dialogue box)
TYPE - "dxdiag" - Click OK

This opens the DirectX diagnostic tool
Click on "Save All Information" - when the SAVE box opens save to a name.txt file

When you post the file use the Preview Post option and select "#" symbol - cut and paste the name.txt file after the "#"
then click on the "Close Tags" that appears at the top of Message window.

You have a STEAM version so try to VERIFY LOCAL FILES in STEAM

and if possible ..........
Did you get an error message or Debugger pop up? Post the screen shot.
Did it just Crash to Desktop (CTD)? With WIN 7 message "Patrician IV has stopped working"?

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Couple of other things to try:-
1. I see you have your STEAM Applications on a different partition from C: - which I assume is the system drive. I think I read somewhere that the game has problems if installed on a different partition from the system drive.
You could try reinstalling the game on to the system partition - check this link about installing STEAM games on a different drive -
https://support.steampowered.com/kb_arti...-tdlc-0426

The other thing is to run a hard check on your RAM - the c0000005 error translates has a memory error - BUT it usually gets output if no other problem can be identified - but there's always that possibility.
Reply
Hi,

When I try to create a route, the next day the route it is auto cancelled, I don't know why but it is imposible to create a route and that this can be enabled in order to trade with other cities. I start a new campaign and the same situation it is been done.

A message appears in alerts with a picture of a scales with a red slash.
Reply
- do you play on higher difficult level and the harbour of the town is frozen?
- does the captain got orders he could fulfill in the town?
Lebe jeden Tag, als wäre es Dein Letzter! / Live each day as it would be your last!
[Image: http://imghost4you.com/images/46.png]
Reply
No,

I can only play if I give automatic orders to the captain in order to buy and sell.
Reply
(10-05-2013, 11:44 PM)gary cruz Wrote: Having a problem with trade route set up, I want to drop of product to storehouse but not sell to city. Every time I change the value in UNLOAD CITY side the same value appears in UNLOAD STOREHOUSE and vice verse

You have selected Trade Route for your Convoy, planned a route for the towns you want to visit, and selected 'My Strategy' - Edit My Strategy.
If you are just dealing with your warehouses along this route, you should just be looking at a single column of values to the right of the goods ICONs. You can load and unload whatever values you want. The game does not check you have the right amounts.

If you are seeing two columns of values then you are dealing with the town and you can trade on price or quantity.

If you still have probems post a screen shot, or your savegame.
Reply
After running my game for a while, say an hour or so, some event videos will pop up without sound and play constantly until I hit Escape. As well as that, certain overlay images no longer appear (blue flags over my buildings, the not enough building materials sign, etc)

Quitting the program and restarting it solves the issue, not exactly a game breaker. It is amusing to see Uncle Lubeck mouth wordlessly to me forever though.


wrong thread, disregard.
Reply
tryy to update Microsoft Frame Network 3.5 (and 4.0 if you want to, but the game needs 3.5) from MS site and then try the game update again.

system and drivers (graphics and sound) are up to date?
Reply
Accepting "Purchase and Deliver" assignments from Town Hall result in immediate inavailablilty of product. "We have a surplus of [any product]. Buy some and deliver to [any location]."

Prior to accepting the assignment they do indeed have a surplus. After accepting the assignment there may be enough to complete the assignment... if you are willing to pay double or more the average value and take a decrease in reputation. This behavior is consistent in all town halls.

The talking heads stopped talking... They pop-up but their audio is no more.
Reply
Hoping someone can help me?

I have installed Patrician IV (v 1.3.0) on my new computer with Windows 8 as an operating system.

After installation the game runs fine on the first attempt. After closing it down, and attempting to run again, i proceed through the launcher to the 'Play Patrician' button which generates the failure notice "Patrician IV has stopped working. A problem caused the program to stop working correctly...".

I have uninstalled and re-installed a few times now with consistent behavior each time, i.e runs first time from install, does not work after that.

Is anyone familiar with this problem and/or have a solution please?

thanks
Reply
First thing to try is to uninstall and reinstall the game to see if the problem persists. (If you have a STEAM version then you can try "Verify Local Content" from your STEAM Library. - Right click game and select properties). If it's an optical install (DVD etc ..) there maybe a "repair" option from the install menu.

If you still have the problem then try running the game in Compatibilty Mode --> http://windows.microsoft.com/en-gb/windo...on-windows

If that doesn't work then you will need to do some further digging.
Open Control Panel, click System and Security, click Administrative Tools, and then double-clicking Event Viewer.
In the left Pane Click WINDOWS LOGS - then Application - it may take a while to load all the info but find the entry for Patrician and click on the Details TAB. Open both the SYSTEM and Event data sections - then cut and paste that into a POST and send it to support@kalypsomedia.com.
Reply
Thank you billyplod. The compatibility correction process fixed it.
Reply




Users browsing this thread: 1 Guest(s)