Patrician IV: Rise of a Dynasty - Bug Reports Thread (Version 2.0.4 only!)
#31
there is an optionin the menu to dis/enable an automatic reset of the camera position if you release the mouse button
Reply
#32
(28-04-2011, 12:48 AM)Falko Wrote: there is an optionin the menu to dis/enable an automatic reset of the camera position if you release the mouse button

Thanks so much! ^^ I will try it out when I get home from work this evening! ;D

EDIT: What is this option called in the options menu? I don't seem to be able to find it...
Reply
#33
As an accountant, by trade, I find this extremely annoying, but there is definitely something wrong with the Income and Expenditures under the Balance tab. I took two screenshots, one on Feb 16, 1372 and one 30 days later on March 17, 1372. The only manual activity I had during those three days was 2 battles against pirates. I lost one crayer and gained one cog, during the battles. So even if that were somehow included in income and expenditures, I would have gained wealth from a higher value ship replacing a lesser value one.

My total Gold amount increased from $443,874 to $815,574 in those 30 days. When I look at the 30-Days column on the March sheet, at the Sum line, it shows I have lost $180,618.

That is absolutely incorrect. Come on programmers. You are better at math than any Accountant, but your addition and subtraction is diabolical!

I had to run some more screenshots so I could compare individual town Balance tabs to the combined Logbook Balance tab. I took a look at the individual town Balance tabs and they seem to add up correctly. Running a quick check of the costs shown when clicking businesses and adding those up, multiplied by 30 days, shows it pretty close to the combined labor costs and land tax costs. Also checking rental income, multiplied by 30 days, is really close to the Balance figure, as well. So, I don't think the error is within individual town data, but the combined data when looking at the Balance tab from the Logbook.

I put together a spreadsheet to compare the summed totals of each individual town Balance tab and compared it to the combined numbers from the Logbook Balance tab. I noticed a few problems.

(1) If you do the math, the Sum on the Balance tab in the Logbook is wrong.
(2) The Domestic Trade value shown, for me 348,307 of income, was missing about 650,000 gold over 30 days, compared to the individual town Balance tabs added up.
(3) The Counting Houses line seems to only be the cost of additional storage, where do the cost of Guards and Administrator go that is shown on the town Balance tabs? Should they be included as part of the Counting House expense line?

Please, fix the reports. They're useless if we're making money and it's telling us we're about to go bankrupt. I hope your managers don't look at reports like these!
Reply
#34
I have similar problems. Is your balance positve after loading the game?
Is your balance decreasing during the fast forward, while simultaneously your cash is increasing?
Reply
#35
(28-04-2011, 11:44 PM)Falko Wrote: I have similar problems. Is your balance positve after loading the game?
Is your balance decreasing during the fast forward, while simultaneously your cash is increasing?

I don't know if fast forwarding has anything to do with it. However, when I loaded up a game, it did seem to be correct. Perhaps the numbers are just degrading over time?
Reply
#36
i seems you have the same problem (fast forwarding was only a suggestion for a quick test)
the first calculation while loading a save is fine but in the update of the balance is a bug
for a economy/trade simulation that should be a major bug
Reply
#37
(28-04-2011, 12:53 PM)Amrasje Wrote: EDIT: What is this option called in the options menu? I don't seem to be able to find it...
i dont have an english version
it should be something like "lock camera"
Reply
#38
(29-04-2011, 09:44 AM)Falko Wrote:
(28-04-2011, 12:53 PM)Amrasje Wrote: EDIT: What is this option called in the options menu? I don't seem to be able to find it...
i dont have an english version
it should be something like "lock camera"

Yup, that's exactly it. Under the Gameplay tab in Options, it's the 5th button down.
Reply
#39
(29-04-2011, 05:23 PM)Bearface Wrote:
(29-04-2011, 09:44 AM)Falko Wrote:
(28-04-2011, 12:53 PM)Amrasje Wrote: EDIT: What is this option called in the options menu? I don't seem to be able to find it...
i dont have an english version
it should be something like "lock camera"

Yup, that's exactly it. Under the Gameplay tab in Options, it's the 5th button down.
Ah! Thanks =D I was looking at the "Graphics" menu... I should be able to get it right now ^^
Reply
#40
After two weeks playing smoothly, I found the first serious problem in P4. I think I got a bug I cannot solve. This is what happens. I created a transport route from Reval (my home) to Lubeck. I designed the following route:

1. Reval. Unload four products coming from Lubeck.
2. Reval. Load two products for Lubeck.
3. Lubeck. Unload two products coming from Reval.
4. Lubeck. Load four products for Reval.

No trading, as you can see. Just moving stuff up and down.

It worked wonderfully with no problem until today. I added a fifth product from Lubeck to Reval. The new route is:

1. Reval. Unload five products coming from Lubeck.
2. Reval. Load two products for Lubeck.
3. Lubeck. Unload two products coming from Reval.
4. Lubeck. Load five products for Reval.

And then KABOOM! Sad A message of "Transport route disabled" is got. The ship unload correctly the dirst time, but then loads the same stuff it unloaded!!! I rewrote the route from scratch, I changed the captain, I changed the ship, but to no avail. I enen tried to reuse the original desing. It doesn't work. Sad

Has anyone seen this bug? Is it common?

Thank you in advance.
Reply
#41
This is very strange. It's doing just the opposite it should do. Once it unloads all stuff, it then reload it imediately after!! Where could I send this to be fixed, please?
Reply
#42
upload ths save to a freehoster nad there is a good chance somebody will take a look at your problem
Reply
#43
The Alderman duties screen in the Guild house is showing a wrong text event.
Is says:
More Wine is being produced then the Hanseatic burghers require.
Causing a shortage of this good could lead to a drop in their level of satisfaction

Measure:
Have an assignment posted for someone to increase production of these good.

Apparently there is being less Wine produced then required and production must increase.

I have noticed this not only with Wine but also with other goods.
Reply
#44
My game seems to crash regularly (not every time) after having played a manual sea battle. Anyone experiencing the same problem?
I wouldn't mind that much, but manual battles seem to last for nearly an hour sometimes (when using a 14-gun crayer against 3 20-gun cogs) and the game doesn't save during manual battles, so it's so much playing time that just got lost... Sad
Reply
#45
(03-05-2011, 04:48 PM)Amrasje Wrote: My game seems to crash regularly (not every time) after having played a manual sea battle. Anyone experiencing the same problem?
I wouldn't mind that much, but manual battles seem to last for nearly an hour sometimes (when using a 14-gun crayer against 3 20-gun cogs) and the game doesn't save during manual battles, so it's so much playing time that just got lost... Sad

First ensure that you are running the latest version of WINDOWS patches, there was a C++ 2005 and 2008 redistributable version patch last evening (C++ redistributable is used by the game).
Run windows update - if your machine is not set to "Automatic"

Then :-
Does it Crash to Desktop - no pop-up with error message?
Is there an entry in the Application or System log in Event viewer?
Is there a DR WATSON log file - is named Drwtsn32.log and is saved in the following location:
drive:\Documents and Settings\All Users.WINNT\Application Data\Microsoft\Dr Watson
this is the default program error debugger.

Post what you have and send it on to KALYSPO support.
Reply
#46
(03-05-2011, 04:48 PM)Amrasje Wrote: I wouldn't mind that much, but manual battles seem to last for nearly an hour sometimes (when using a 14-gun crayer against 3 20-gun cogs)

You can hold down the Space Bar on your keyboard to move things at 10x speed.

Reply
#47
(28-04-2011, 11:34 PM)Bearface Wrote: As an accountant, by trade, I find this extremely annoying, but there is definitely something wrong with the Income and Expenditures under the Balance tab. [...]

Hi! Do you have a savegame for both states?
Probably the difference is caused by some missions (maybe a loan) or a tresure.
(29-04-2011, 10:31 PM)Landmeister Wrote: After two weeks playing smoothly, I found the first serious problem in P4. I think I got a bug I cannot solve. This is what happens. I created a transport route from Reval (my home) to Lubeck. [...]

Do you have a savegame to reproduce this issue?
Maybe the harbour where your convoy currently is anchored is frozen...


(02-05-2011, 05:00 PM)spacemouse Wrote: The Alderman duties screen in the Guild house is showing a wrong text event.
Is says:
[...]

Do you have a savegame to reproduce that issue? Please send it to support@kalypsomedia.com with a request to forwarding it to GamingMinds.
Reply
#48
When goods are moved to and from a Wagon Train to a Counting House the total storage value does not update.

Picture 1000 words etc....

[Image: http://www.image-share.com/upload/638/73.jpg]
Reply
#49
That's right, but as soon you leave and enter the market hall again the value will be updated and displayed correctly Wink
Reply
#50
(05-05-2011, 06:46 PM)Daan Hugo Wrote: That's right, but as soon you leave and enter the market hall again the value will be updated and displayed correctly Wink

Yes! but with sea convoy's the value updates - in real time - while you are loading, unloading or trading. This helps in ensuring you don't go over the storage maxium and incur costs.
Reply
#51
Thank you. Bug acknowledged. Smile
Reply
#52
(04-05-2011, 02:43 PM)Daan Hugo Wrote:
(29-04-2011, 10:31 PM)Landmeister Wrote: After two weeks playing smoothly, I found the first serious problem in P4. I think I got a bug I cannot solve. This is what happens. I created a transport route from Reval (my home) to Lubeck. [...]
Do you have a savegame to reproduce that issue? Please send it to support@kalypsomedia.com with a request to forwarding it to GamingMinds.

Hi I finally reloaded the game from a previous position in the save game and it works correctly now. Don't ask me why, but the problem disappeared. Tongue

Thank you very much.

Reply
#53
(03-05-2011, 07:50 PM)billyplod Wrote:
(03-05-2011, 04:48 PM)Amrasje Wrote: My game seems to crash regularly (not every time) after having played a manual sea battle. Anyone experiencing the same problem?
I wouldn't mind that much, but manual battles seem to last for nearly an hour sometimes (when using a 14-gun crayer against 3 20-gun cogs) and the game doesn't save during manual battles, so it's so much playing time that just got lost... Sad

First ensure that you are running the latest version of WINDOWS patches, there was a C++ 2005 and 2008 redistributable version patch last evening (C++ redistributable is used by the game).
Run windows update - if your machine is not set to "Automatic"

Then :-
Does it Crash to Desktop - no pop-up with error message?
Is there an entry in the Application or System log in Event viewer?
Is there a DR WATSON log file - is named Drwtsn32.log and is saved in the following location:
drive:\Documents and Settings\All Users.WINNT\Application Data\Microsoft\Dr Watson
this is the default program error debugger.

Post what you have and send it on to KALYSPO support.

Hi! Apart from asking for help on here, I also sent an e-mail to the Kalypso Media Support team, along with a dxdiag. The friendly people there told me my drivers were getting a bit old, so I updated them and haven't had the problem since. If it should happen again, though, I will get back to you!
Thanks for helping me out! ^^
Reply
#54
The shadow map:

[Image: http://dc318.4shared.com/img/Sxrq97Q2/s3..._00002.jpg]

I bought four pieces of map... but... where is my treasure? Rolleyes
Reply
#55
(13-05-2011, 09:35 AM)Xelaehtgre Wrote: The shadow map:

[Image: http://dc318.4shared.com/img/Sxrq97Q2/s3..._00002.jpg]

I bought four pieces of map... but... where is my treasure? Rolleyes

Is this bug reproduceable? Do you have any savegame?
Reply
#56
(13-05-2011, 10:57 AM)Daan Hugo Wrote: Is this bug reproduceable? Do you have any savegame?

unfortunately no
Reply
#57
(13-05-2011, 07:50 PM)DWhite6666 Wrote: I have just aquired Patrician 4 from steam download and I have a graphics problem while viewing the town. In the town display there is a vertical line down the center and the town and buildings on the right are normal and the left side is entirely blue with black boxes with titles in them. I am using a Nvidia GTX480 at 1920x1080 res. Windows 7 64bit with DX11. I have tried several different resolutions with no difference. When i exit the town and view the sea/continents the view is normal.

This sounds (or should I say looks) like a 3D problem - the Game doesn't support 3D - You can set the 3D option in NVIDIA Control panel to "Let the application decide" or turn off 3D

Check out this thread.

http://forum.kalypsomedia.com/showthread...t=Graphics
Reply
#58
Bug: Unable to switch between counting house and city, while counting house is shown in the trade route and no counting house is present in the city.
Status: Major

Description:

When editing a route that is saved from a previous game, occasionally a counting house is shown to unload goods; even when there's no counting house in that city at the time. Player is also unable to switch between the counting house and the city.
Possible causes: Route is saved another game, where a counting house was in that city or wrong image is shown.

More information, screenshots and a possible workaround is shown in this thread.


Thorin Smile
Hack seinen Kopf ab. Ich brauche einen Aschenbecher!
Reply
#59
please read the text "for the next rank you need" ...
for all ranks (except patrician) there is the information how much stuff you need for the next rank
if you reach patrician then the correct wealth is shown
Reply
#60
(08-04-2011, 12:22 AM)billyplod Wrote: Copied from post from V2.0.3 patch and still happening in V2.0.4
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
When a sea battle starts, the movement is "jerky" - Staccato. Like old black & white movies on hand cranked projectors (no I'm not that old) but it's the best way to explain. Then after 3 or 4 minutes, the movement settles down and becomes smooth.
Tried on all graphics settings LOW to VERY HIGH and effect is the same on all of them.
Running with --
Geforce GS 7900 - 256 MB and 266.58 (latest Driver)
Dual core Intel 6700 - 2.66Ghz Processor
3Gb Memory.

The Original P4 sea battles do not display this problem.
The sea is being rendered differently from P4 original the overlay tile grid is visible.
"Cloud Shadow" is an option on the Graphics TAB but no cloud shadows are displayed if the option is selected.

Also it seems that it isn't time that stops the jerky movement but increasing the game speed to 10x on the main map
and 5x in sea battles, sometimes requires several attempts , but after this speed increase, the movement returns to "normal" - ie. No "hop skipping" but smooth movement.

Anyone else try this and see what the outcome is?

I've been testing this a bit more and here are my discoveries:

- Game is jerky at speeds 1,2 & 3, with or without shadows and at all stages between maximum zooming in and maximum zooming out. At 3x speed the game becomes more or less playable after several minutes. The other two speed levels remain jerky for such a long time, I decided to skip them.
- Game is jerky at speed 5 with shadows and zoomed in at default level. When zoomed in or zoomed out to the maximum, the game runs pretty smooth.
Without shadows the game runs a lot better and is quite playable.
At 10 speed the game runs without problems.
However, when "dropping" back to the orignal set speed, even 5x, the game stutters, untill it returns to running smooth after 2-3 minutes.

Because of this, the naval battles are best fought at 3x or 5x speed and with as less use of the spacebar (10x speed) as possible.
Disadvantage of using 5x speed is that the player has little time to react to AI actions, making 3x speed the best choice to fight the battles manually.


Thorin Smile
Hack seinen Kopf ab. Ich brauche einen Aschenbecher!
Reply




Users browsing this thread: 1 Guest(s)